# CVE-2019-9644: Improper Neutralization of Input During Web Page Generation in Jupyter Notebook

> An XSSI vulnerability in Jupyter Notebook allows attackers to read resource content via malicious pages when authenticated users visit them.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-9644, GHSA-hhx8-cr55-qcxx, PYSEC-2019-159, PYSEC-2026-2531, UBUNTU-CVE-2019-9644

## What is CVE-2019-9644?

CVE-2019-9644 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows inclusion of resources on malicious pages when visited by users who are authenticated with a Jupyter server. Access to the content of resources has been demonstrated with Internet Explorer through capturing of error messages, though not reproduced with other browsers. This occurs because Internet Explorer's error messages can include the content of any invalid JavaScript that was encountered.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-9644?

6 open source packages ship an affected version, including jupyter-notebook and notebook. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-notebook` | PyPI | All versions | 5.7.6 |
| `jupyter-notebook` | PyPI | All versions | 5.7.6 |
| `jupyter-notebook` | PyPI | All versions | 5.7.6 |
| `notebook` | PyPI | All versions | 5.7.6 |
| `notebook` | PyPI | All versions | 5.7.6 |
| `notebook` | PyPI | All versions | 5.7.6 |

Products: Jupyter Notebook.

## How do I fix CVE-2019-9644?

Upgrade jupyter-notebook to 5.7.6 or later.

## Is CVE-2019-9644 being exploited?

There is no known exploitation of CVE-2019-9644 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-32798](https://insights.sbomify.com/CVE-2021-32798/): Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in notebook (critical 10.0)
- [CVE-2018-8768](https://insights.sbomify.com/CVE-2018-8768/): Jupyter Notebook file bypasses sanitization, executes JavaScript (high 7.8)
- [CVE-2022-24758](https://insights.sbomify.com/CVE-2022-24758/): Insertion of Sensitive Information into Log File affects Jupyter Notebook (high 7.5)
- [CVE-2019-10856](https://insights.sbomify.com/CVE-2019-10856/): Jupyter Notebook open redirect vulnerability (medium 6.1)
- [CVE-2018-19351](https://insights.sbomify.com/CVE-2018-19351/): Jupyter Notebook XSS via untrusted notebooks (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9644 and fix it if it is affected.

What it is: CVE-2019-9644 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-9644 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-notebook (PyPI): affected all versions; fixed in 5.7.6
- jupyter-notebook (PyPI): affected all versions; fixed in 5.7.6
- jupyter-notebook (PyPI): affected all versions; fixed in 5.7.6
- notebook (PyPI): affected all versions; fixed in 5.7.6
- notebook (PyPI): affected all versions; fixed in 5.7.6
- notebook (PyPI): affected all versions; fixed in 5.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9644/ (Markdown: https://insights.sbomify.com/CVE-2019-9644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9644
- OSV: https://osv.dev/vulnerability/CVE-2019-9644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9644/
Summaries are generated and may contain mistakes; the official description above is the record.
