# CVE-2019-9658: Moderate severity vulnerability that affects com.puppycrawl.tools:checkstyle

> Checkstyle loads external DTDs by default, allowing attackers to perform XML External Entity attacks to read files or cause denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-9658, DLA-1768-1, GHSA-gp32-7h29-rpxm, UBUNTU-CVE-2019-9658

## What is CVE-2019-9658?

CVE-2019-9658 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Checkstyle before 8.18 loads external DTDs by default.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-9658?

2 open source packages ship an affected version, including com.puppycrawl.tools:checkstyle. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.puppycrawl.tools:checkstyle` | Maven | All versions | 8.18 |
| `com.puppycrawl.tools:checkstyle` | Maven | All versions | 8.18 |

Products: Checkstyle Checkstyle, Debian Debian Linux, Fedoraproject Fedora.

## How do I fix CVE-2019-9658?

Upgrade com.puppycrawl.tools:checkstyle to 8.18 or later.

## Is CVE-2019-9658 being exploited?

There is no known exploitation of CVE-2019-9658 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2019-10782](https://insights.sbomify.com/CVE-2019-10782/): XML external entity (XXE) processing ('external-parameter-entities' feature was not fully disabled)) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9658 and fix it if it is affected.

What it is: CVE-2019-9658 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9658 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.puppycrawl.tools:checkstyle (Maven): affected all versions; fixed in 8.18
- com.puppycrawl.tools:checkstyle (Maven): affected all versions; fixed in 8.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9658/ (Markdown: https://insights.sbomify.com/CVE-2019-9658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9658
- OSV: https://osv.dev/vulnerability/CVE-2019-9658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9658/
Summaries are generated and may contain mistakes; the official description above is the record.
