# CVE-2019-9710: Webargs mishandles concurrent JSON parsing

> Concurrent requests may receive incorrect JSON payloads due to a thread-unsafe cache in the webargs library, potentially leading to data integrity issues.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8554-jxcw-454q, PYSEC-2019-139

## What is CVE-2019-9710?

CVE-2019-9710 is a high-severity vulnerability in n/a, published on 12 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in webargs before 5.1.3, as used with marshmallow and other products. JSON parsing uses a short-lived cache to store the parsed JSON body. This cache is not thread-safe, meaning that incorrect JSON payloads could have been parsed for concurrent requests.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2019-9710?

3 open source packages ship an affected version, including webargs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webargs` | PyPI | All versions | 5.1.3 |
| `webargs` | PyPI | All versions | 5.1.3 |
| `webargs` | PyPI | All versions | 5.1.3 |

Products: Webargs Project Webargs.

## How do I fix CVE-2019-9710?

Upgrade webargs to 5.1.3 or later.

## Is CVE-2019-9710 being exploited?

There is no known exploitation of CVE-2019-9710 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-7965](https://insights.sbomify.com/CVE-2020-7965/): Cross-Site Request Forgery in Webargs (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9710 and fix it if it is affected.

What it is: CVE-2019-9710 is a high-severity vulnerability in n/a, published on 12 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9710 in the wild and no public exploit code.

Affected packages and fixed versions:
- webargs (PyPI): affected all versions; fixed in 5.1.3
- webargs (PyPI): affected all versions; fixed in 5.1.3
- webargs (PyPI): affected all versions; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9710/ (Markdown: https://insights.sbomify.com/CVE-2019-9710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9710
- OSV: https://osv.dev/vulnerability/CVE-2019-9710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9710/
Summaries are generated and may contain mistakes; the official description above is the record.
