# CVE-2019-9735: OpenStack Neutron's unsupported dport option prevents applying security groups

> An authenticated user can cause a denial of service by blocking security group rule applications on compute hosts using specific iptables configurations.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-9735, DSA-4409-1, GHSA-9773-3fqg-8w25, PYSEC-2019-190, RHSA-2019:0916, UBUNTU-CVE-2019-9735, USN-4036-1

## What is CVE-2019-9735?

CVE-2019-9735 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 13 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in the iptables firewall module in OpenStack Neutron before 10.0.8, 11.x before 11.0.7, 12.x before 12.0.6, and 13.x before 13.0.3. By setting a destination port in a security group rule along with a protocol that doesn't support that option (for example, VRRP), an authenticated user may block further application of security group rules for instances from any project/tenant on the compute hosts to which it's applied. (Only deployments using the iptables security group driver are affected.)

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2019-9735?

9 open source packages ship an affected version, including neutron. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | All versions | 10.0.8 |
| `neutron` | PyPI | All versions | 10.0.8 |
| `neutron` | PyPI | From 11.0.0 | 11.0.7 |
| `neutron` | PyPI | From 11.0.0 | 11.0.7 |
| `neutron` | PyPI | From 12.0.0 | 12.0.6, 13.0.3, 11.0.7, 10.0.8 |
| `neutron` | PyPI | From 12.0.0 | 12.0.6 |
| `neutron` | PyPI | From 12.0.0 | 12.0.6 |
| `neutron` | PyPI | From 13.0.0 | 13.0.3 |
| `neutron` | PyPI | From 13.0.0 | 13.0.3 |
| `openstack-neutron` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-bigswitch-agent` | Red Hat:openstack:10::el7 | All versions | 2:9.42.14-1.el7ost |
| `openstack-neutron-bigswitch-lldp` | Red Hat:openstack:10::el7 | All versions | 2:9.42.14-1.el7ost |
| `openstack-neutron-common` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-lbaas` | Red Hat:openstack:10::el7 | All versions | 1:9.2.2-8.el7ost |
| `openstack-neutron-linuxbridge` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-macvtap-agent` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-metering-agent` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-ml2` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-openvswitch` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-rpc-server` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `openstack-neutron-sriov-nic-agent` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `python-networking-bigswitch` | Red Hat:openstack:10::el7 | All versions | 2:9.42.14-1.el7ost |
| `python-neutron` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |
| `python-neutron-lbaas` | Red Hat:openstack:10::el7 | All versions | 1:9.2.2-8.el7ost |
| `python-neutron-lbaas-tests` | Red Hat:openstack:10::el7 | All versions | 1:9.2.2-8.el7ost |
| `python-neutron-tests` | Red Hat:openstack:10::el7 | All versions | 1:9.4.1-40.el7ost |

Products: Debian Debian Linux, Openstack Neutron, Redhat Openstack.

## How do I fix CVE-2019-9735?

Upgrade neutron to a fixed version for your release line: 10.0.8, 11.0.7, 12.0.6 or 13.0.3.

## Is CVE-2019-9735 being exploited?

There is no known exploitation of CVE-2019-9735 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9735 and fix it if it is affected.

What it is: CVE-2019-9735 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 13 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9735 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected all versions; fixed in 10.0.8
- neutron (PyPI): affected all versions; fixed in 10.0.8
- neutron (PyPI): affected from 11.0.0; fixed in 11.0.7
- neutron (PyPI): affected from 11.0.0; fixed in 11.0.7
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.6, 13.0.3, 11.0.7, 10.0.8
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.6
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.6
- neutron (PyPI): affected from 13.0.0; fixed in 13.0.3
- neutron (PyPI): affected from 13.0.0; fixed in 13.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9735/ (Markdown: https://insights.sbomify.com/CVE-2019-9735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9735
- OSV: https://osv.dev/vulnerability/CVE-2019-9735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9735/
Summaries are generated and may contain mistakes; the official description above is the record.
