# CVE-2019-9764: HashiCorp Consul vulnerable to Origin Validation Error

> HashiCorp Consul fails to verify server hostnames in TLS, allowing attackers to bypass security controls and potentially intercept or manipulate agent-to-agent communications.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q7fx-wm2p-qfj8, GO-2023-1853, UBUNTU-CVE-2019-9764

## What is CVE-2019-9764?

CVE-2019-9764 is a high-severity vulnerability in n/a, published on 26 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Consul 1.4.3 lacks server hostname verification for agent-to-agent TLS communication. In other words, the product behaves as if verify_server_hostname were set to false, even when it is actually set to true. This is fixed in 1.4.4.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2019-9764?

3 open source packages ship an affected version, including github.com/hashicorp/consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | All versions | 1.4.4 |
| `github.com/hashicorp/consul` | Go | All versions | 1.4.4 |
| `github.com/hashicorp/consul` | Go | All versions | 1.4.4 |

Products: Hashicorp Consul.

## How do I fix CVE-2019-9764?

Upgrade github.com/hashicorp/consul to 1.4.4 or later.

## Is CVE-2019-9764 being exploited?

There is no known exploitation of CVE-2019-9764 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9764 and fix it if it is affected.

What it is: CVE-2019-9764 is a high-severity vulnerability in n/a, published on 26 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9764 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.4.4
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.4.4
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9764/ (Markdown: https://insights.sbomify.com/CVE-2019-9764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9764
- OSV: https://osv.dev/vulnerability/CVE-2019-9764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9764/
Summaries are generated and may contain mistakes; the official description above is the record.
