# CVE-2019-9827: Server-Side Request Forgery in Hawt Hawtio

> Remote attackers can trigger arbitrary HTTP requests from the server via the proxy endpoint, potentially accessing internal resources.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mcg9-64cp-xwp7

## What is CVE-2019-9827?

CVE-2019-9827 is a critical server-side request forgery vulnerability in n/a, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hawt Hawtio through 2.5.0 is vulnerable to SSRF, allowing a remote attacker to trigger an HTTP request from an affected server to an arbitrary host via the initial /proxy/ substring of a URI.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2019-9827?

2 open source packages ship an affected version, including io.hawt:hawtio-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.hawt:hawtio-core` | Maven | All versions | 2.5.0 |
| `io.hawt:hawtio-core` | Maven | All versions | 2.5.0 |

Products: Hawt Hawtio.

## How do I fix CVE-2019-9827?

Upgrade io.hawt:hawtio-core to 2.5.0 or later.

## Is CVE-2019-9827 being exploited?

There is no known exploitation of CVE-2019-9827 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-0121](https://insights.sbomify.com/CVE-2014-0121/): Missing authorization in n/a (critical 9.8)
- [CVE-2014-0120](https://insights.sbomify.com/CVE-2014-0120/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2017-7556](https://insights.sbomify.com/CVE-2017-7556/): Cross-Site Request Forgery in hawtio (high 8.8)
- [CVE-2017-2589](https://insights.sbomify.com/CVE-2017-2589/): Insecure cookie sharing in Hawtio (high 8.7)
- [CVE-2017-2617](https://insights.sbomify.com/CVE-2017-2617/): File upload in hawtio (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9827 and fix it if it is affected.

What it is: CVE-2019-9827 is a critical server-side request forgery vulnerability in n/a, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9827 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.hawt:hawtio-core (Maven): affected all versions; fixed in 2.5.0
- io.hawt:hawtio-core (Maven): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9827/ (Markdown: https://insights.sbomify.com/CVE-2019-9827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9827
- OSV: https://osv.dev/vulnerability/CVE-2019-9827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9827/
Summaries are generated and may contain mistakes; the official description above is the record.
