{"answers":{"affected":"2 open source packages ship an affected version, including doorkeeper-openid_connect. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-9837 in the wild and no public exploit code.","fix":"Upgrade doorkeeper-openid_connect to 1.5.4 or later.","what":"CVE-2019-9837 is a medium-severity vulnerability in n/a, published on 15 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-9837 and fix it if it is affected.\n\nWhat it is: CVE-2019-9837 is a medium-severity vulnerability in n/a, published on 15 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-9837 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- doorkeeper-openid_connect (RubyGems): affected from 1.4.0; fixed in 1.5.4\n- doorkeeper-openid_connect (RubyGems): affected from 1.4.0; fixed in 1.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-9837/ (Markdown: https://insights.sbomify.com/CVE-2019-9837/index.md)","id":"CVE-2019-9837","markdown":"https://insights.sbomify.com/CVE-2019-9837/index.md","name":"CVE-2019-9837","record":{"aliases":["DEBIAN-CVE-2019-9837","GHSA-vv4c-g6q7-p3q7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth library","requires_auth":"none","summary":"An open redirect in the Doorkeeper OpenID Connect extension allows attackers to redirect users to malicious sites during OAuth authorization errors, facilitating phishing attacks.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openid_connect","vendor":"openid"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Doorkeeper::OpenidConnect (aka the OpenID Connect extension for Doorkeeper) 1.4.x and 1.5.x before 1.5.4 has an open redirect via the redirect_uri field in an OAuth authorization request (that results in an error response) with the 'openid' scope and a prompt=none value. This allows phishing attacks against the authorization flow.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Doorkeeper-openid_connect contains Open Redirect","id":"CVE-2019-9837","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"open_redirect","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-9838"},"packages":[{"ecosystem":"RubyGems","fixed":["1.5.4"],"introduced":["1.4.0"],"last_affected":[],"package":"doorkeeper-openid_connect","purl":null,"source":"GHSA-vv4c-g6q7-p3q7"},{"ecosystem":"RubyGems","fixed":["1.5.4"],"introduced":["1.4.0"],"last_affected":[],"package":"doorkeeper-openid_connect","purl":"pkg:gem/doorkeeper-openid_connect","source":"GHSA-vv4c-g6q7-p3q7"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2019-9836"},"products":["n/a"],"published":"2019-03-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An open redirect in the Doorkeeper OpenID Connect extension allows attackers to redirect users to malicious sites during OAuth authorization errors, facilitating phishing attacks.","url":"https://insights.sbomify.com/CVE-2019-9837/"}