# CVE-2019-9837: Doorkeeper-openid_connect contains Open Redirect

> An open redirect in the Doorkeeper OpenID Connect extension allows attackers to redirect users to malicious sites during OAuth authorization errors, facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-9837, GHSA-vv4c-g6q7-p3q7

## What is CVE-2019-9837?

CVE-2019-9837 is a medium-severity vulnerability in n/a, published on 15 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Doorkeeper::OpenidConnect (aka the OpenID Connect extension for Doorkeeper) 1.4.x and 1.5.x before 1.5.4 has an open redirect via the redirect_uri field in an OAuth authorization request (that results in an error response) with the 'openid' scope and a prompt=none value. This allows phishing attacks against the authorization flow.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2019-9837?

2 open source packages ship an affected version, including doorkeeper-openid_connect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `doorkeeper-openid_connect` | RubyGems | From 1.4.0 | 1.5.4 |
| `doorkeeper-openid_connect` | RubyGems | From 1.4.0 | 1.5.4 |

Products: Openid Openid Connect.

## How do I fix CVE-2019-9837?

Upgrade doorkeeper-openid_connect to 1.5.4 or later.

## Is CVE-2019-9837 being exploited?

There is no known exploitation of CVE-2019-9837 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9837 and fix it if it is affected.

What it is: CVE-2019-9837 is a medium-severity vulnerability in n/a, published on 15 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-9837 in the wild and no public exploit code.

Affected packages and fixed versions:
- doorkeeper-openid_connect (RubyGems): affected from 1.4.0; fixed in 1.5.4
- doorkeeper-openid_connect (RubyGems): affected from 1.4.0; fixed in 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9837/ (Markdown: https://insights.sbomify.com/CVE-2019-9837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9837
- OSV: https://osv.dev/vulnerability/CVE-2019-9837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9837/
Summaries are generated and may contain mistakes; the official description above is the record.
