# CVE-2019-9901: EnvoyProxy Envoy Missing HTTP URL path normalization

> Remote attackers can bypass access control policies by sending non-normalized HTTP paths, potentially accessing restricted backend resources.

- **Severity:** Medium 6.5 (`CVSS:3.0/AC:H/AV:N/A:L/C:L/I:L/PR:N/S:C/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2wmf-p7f8-w42h, GHSA-xcx5-93pw-jw2w

## What is CVE-2019-9901?

CVE-2019-9901 is a medium-severity vulnerability in Envoyproxy Envoy, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy 1.9.0 and before does not normalize HTTP URL paths. A remote attacker may craft a relative path, e.g., something/../admin, to bypass access control, e.g., a block on /admin. A backend server could then interpret the non-normalized path and provide an attacker access beyond the scope provided for by the access control policy.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2019-9901?

2 open source packages ship an affected version, including github.com/envoyproxy/envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/envoy` | Go | All versions | 1.9.1 |
| `github.com/envoyproxy/envoy` | Go | All versions | 1.9.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2019-9901?

Upgrade github.com/envoyproxy/envoy to 1.9.1 or later.

## Is CVE-2019-9901 being exploited?

There is no known exploitation of CVE-2019-9901 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-9901 and fix it if it is affected.

What it is: CVE-2019-9901 is a medium-severity vulnerability in Envoyproxy Envoy, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-9901 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/envoy (Go): affected all versions; fixed in 1.9.1
- github.com/envoyproxy/envoy (Go): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-9901/ (Markdown: https://insights.sbomify.com/CVE-2019-9901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-9901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-9901
- OSV: https://osv.dev/vulnerability/CVE-2019-9901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-9901/
Summaries are generated and may contain mistakes; the official description above is the record.
