CVE-2019-9942 Twig Sandbox Information Disclosure

Low 3.7 Published Updated

An attacker can bypass Twig sandbox restrictions to call __toString() on unauthorized objects, potentially disclosing sensitive information.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-9942?

CVE-2019-9942 is a low-severity vulnerability in Debian Debian Linux, published on 23 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A sandbox information disclosure exists in Twig before 1.38.0 and 2.x before 2.7.0 because, under some circumstances, it is possible to call the __toString() method on an object even if not allowed by the security policy in place.

Which versions are affected by CVE-2019-9942?

4 open source packages ship an affected version, including twig/twig. It affects 2 products.

PackageAffectedFixed in
twig/twig PackagistAll versions1.38.0
twig/twig PackagistAll versions1.38.0
twig/twig PackagistFrom 2.0.02.7.0
twig/twig PackagistFrom 2.0.02.7.0

Products include Debian Debian Linux, Symfony Twig.

How do I fix CVE-2019-9942?

Upgrade twig/twig to a fixed version for your release line: 1.38.0 or 2.7.0.

Is CVE-2019-9942 being exploited?

There is no known exploitation of CVE-2019-9942 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DSA-4419-1, GHSA-vxrc-68xx-x48g, UBUNTU-CVE-2019-9942.

Is CVE-2019-9942 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free