CVE-2019-9947 Other in n/a
Attackers can inject CRLF sequences into HTTP headers or Redis commands via URL parameters in Python's urllib, potentially leading to request smuggling or cache poisoning.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-9947?
CVE-2019-9947 is a medium-severity vulnerability in Python Python, published on 23 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in urllib2 in Python 2.x through 2.7.16 and urllib in Python 3.x through 3.7.3. CRLF injection is possible if the attacker controls a url parameter, as demonstrated by the first argument to urllib.request.urlopen with \r\n (specifically in the path component of a URL that lacks a ? character) followed by an HTTP header or a Redis command. This is similar to the CVE-2019-9740 query string issue. This is fixed in: v2.7.17, v2.7.17rc1, v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v3.6.10, v3.6.10rc1, v3.6.11, v3.6.11rc1, v3.6.12, v3.6.9, v3.6.9rc1; v3.7.4, v3.7.4rc1, v3.7.4rc2, v3.7.5, v3.7.5rc1, v3.7.6, v3.7.6rc1, v3.7.7, v3.7.7rc1, v3.7.8, v3.7.8rc1, v3.7.9.
Weakness: CWE-93
Which versions are affected by CVE-2019-9947?
It affects 1 product.
Linux distribution packages (23)
python-futures SUSE:Enterprise Storage 5 | All versions | 3.0.2-15.3.1 |
python-botocore SUSE:HPE Helion OpenStack 8 | All versions | 1.13.33-28.20.1 |
python-futures SUSE:HPE Helion OpenStack 8 | All versions | 3.0.2-15.3.1 |
python-futures SUSE:Linux Enterprise Module for Advanced Systems Management 12 | All versions | 3.0.2-15.3.1 |
python3 SUSE:Linux Enterprise Module for Basesystem 15 | All versions | 3.6.8-3.16.2 |
python3-base SUSE:Linux Enterprise Module for Basesystem 15 | All versions | 3.6.8-3.16.2 |
python3 SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 3.6.8-3.16.2 |
python3-base SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 3.6.8-3.16.2 |
python3-base SUSE:Linux Enterprise Module for Development Tools 15 | All versions | 3.6.8-3.16.2 |
python3-base SUSE:Linux Enterprise Module for Development Tools 15 SP1 | All versions | 3.6.8-3.16.2 |
python-boto3 SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.10.33-14.14.1 |
python-botocore SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.13.33-28.20.1 |
python-futures SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 3.0.2-15.3.1 |
python-s3transfer SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 0.2.1-8.7.1 |
python-futures SUSE:Linux Enterprise Point of Sale 12 SP2 | All versions | 3.0.2-15.3.1 |
python-futures SUSE:Manager Client Tools 12 | All versions | 3.0.2-15.3.1 |
python-futures SUSE:Manager Proxy 3.2 | All versions | 3.0.2-15.3.1 |
python-futures SUSE:Manager Server 3.2 | All versions | 3.0.2-15.3.1 |
python-futures SUSE:OpenStack Cloud 7 | All versions | 3.0.2-15.3.1 |
python-botocore SUSE:OpenStack Cloud 8 | All versions | 1.13.33-28.20.1 |
python-futures SUSE:OpenStack Cloud 8 | All versions | 3.0.2-15.3.1 |
python-botocore SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.13.33-28.20.1 |
python-futures SUSE:OpenStack Cloud Crowbar 8 | All versions | 3.0.2-15.3.1 |
Products include Python Python.
How do I fix CVE-2019-9947?
Upgrade to a fixed version.
Is CVE-2019-9947 being exploited?
There is no known exploitation of CVE-2019-9947 in the wild and no public exploit code.
Other vulnerabilities in Python Python
Sources
Also known as AZL-84281, DEBIAN-CVE-2019-9947, GHSA-89ff-5r66-wr8j, PSF-2019-11, SUSE-RU-2020:0775-1, SUSE-SU-2019:1352-1 and 2 more.