# CVE-2020-0603: Remote code execution in ASP.NET Core

> An attacker can execute arbitrary code by exploiting a memory handling flaw in ASP.NET Core, requiring immediate patching.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-aspnet-core-2020-0603, GHSA-655q-9gvg-q4cm

## What is CVE-2020-0603?

CVE-2020-0603 is a high-severity memory corruption vulnerability in Redhat Enterprise Linux, published on 14 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A remote code execution vulnerability exists in ASP.NET Core software when the software fails to handle objects in memory.An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user, aka 'ASP.NET Core Remote Code Execution Vulnerability'.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2020-0603?

29 open source packages ship an affected version, including Microsoft.AspNetCore.App.Runtime.linux-arm, aspnet-core and Microsoft.AspNetCore.All. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.AspNetCore.App.Runtime.linux-arm` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-arm` | NuGet | From 3.1.0 | 3.1.1 |
| `aspnet-core` | Bitnami | From 2.1.0 | 2.1.1, 3.0.1, 3.1.1 |
| `Microsoft.AspNetCore.All` | NuGet | From 2.1.0 | 2.1.15 |
| `Microsoft.AspNetCore.All` | NuGet | From 2.1.0 | 2.1.15 |
| `Microsoft.AspNetCore.App` | NuGet | From 2.1.0 | 2.1.15 |
| `Microsoft.AspNetCore.App` | NuGet | From 2.1.0 | 2.1.15 |
| `Microsoft.AspNetCore.App` | NuGet | From 3.0.0 | 3.0.1 |
| `Microsoft.AspNetCore.App` | NuGet | From 3.0.0 | 3.0.1 |
| `Microsoft.AspNetCore.App` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-arm64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-arm64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-musl-arm64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-musl-arm64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-musl-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-musl-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.linux-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.osx-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.osx-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.win-arm` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.win-arm` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.win-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.win-x64` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.win-x86` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.App.Runtime.win-x86` | NuGet | From 3.1.0 | 3.1.1 |
| `Microsoft.AspNetCore.Http.Connections` | NuGet | From 1.0.0 | 1.0.15 |
| `Microsoft.AspNetCore.Http.Connections` | NuGet | From 1.0.0 | 1.0.15 |

Products: Microsoft Asp.net Core, Redhat Enterprise Linux, Redhat Enterprise Linux Eus.

## How do I fix CVE-2020-0603?

Upgrade Microsoft.AspNetCore.App.Runtime.linux-arm to 3.1.1 or later.

## Is CVE-2020-0603 being exploited?

There is no known exploitation of CVE-2020-0603 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2025-55315](https://insights.sbomify.com/CVE-2025-55315/): ASP.NET Security Feature Bypass Vulnerability (critical 9.9)
- [CVE-2026-88092](https://insights.sbomify.com/CVE-2026-88092/): ASP.NET Core Tampering Vulnerability (critical 9.4)
- [CVE-2026-40372](https://insights.sbomify.com/CVE-2026-40372/): ASP.NET Core Elevation of Privilege Vulnerability (critical 9.1)
- [CVE-2021-43877](https://insights.sbomify.com/CVE-2021-43877/): ASP.NET Core and Visual Studio Elevation of Privilege Vulnerability (high 8.8)
- [CVE-2019-1302](https://insights.sbomify.com/CVE-2019-1302/): Elevation of privilege in ASP.NET Core (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-0603 and fix it if it is affected.

What it is: CVE-2020-0603 is a high-severity memory corruption vulnerability in Redhat Enterprise Linux, published on 14 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-0603 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.AspNetCore.App.Runtime.linux-arm (NuGet): affected from 3.1.0; fixed in 3.1.1
- Microsoft.AspNetCore.App.Runtime.linux-arm (NuGet): affected from 3.1.0; fixed in 3.1.1
- aspnet-core (Bitnami): affected from 2.1.0; fixed in 2.1.1, 3.0.1, 3.1.1
- Microsoft.AspNetCore.All (NuGet): affected from 2.1.0; fixed in 2.1.15
- Microsoft.AspNetCore.All (NuGet): affected from 2.1.0; fixed in 2.1.15
- Microsoft.AspNetCore.App (NuGet): affected from 2.1.0; fixed in 2.1.15
- Microsoft.AspNetCore.App (NuGet): affected from 2.1.0; fixed in 2.1.15
- Microsoft.AspNetCore.App (NuGet): affected from 3.0.0; fixed in 3.0.1
- Microsoft.AspNetCore.App (NuGet): affected from 3.0.0; fixed in 3.0.1
- Microsoft.AspNetCore.App (NuGet): affected from 3.1.0; fixed in 3.1.1
- Microsoft.AspNetCore.App (NuGet): affected from 3.1.0; fixed in 3.1.1
- Microsoft.AspNetCore.App.Runtime.linux-arm64 (NuGet): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-0603/ (Markdown: https://insights.sbomify.com/CVE-2020-0603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-0603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-0603
- OSV: https://osv.dev/vulnerability/CVE-2020-0603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-0603/
Summaries are generated and may contain mistakes; the official description above is the record.
