CVE-2020-10018 Use after free in n/a

Critical 9.8 Published Updated

A use-after-free vulnerability in WebKitGTK allows attackers to execute arbitrary code via malicious web content.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-10018?

CVE-2020-10018 is a critical use after free vulnerability in Canonical Ubuntu Linux, published on 2 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.

Weakness: CWE-416

Which versions are affected by CVE-2020-10018?

It affects 6 products.

Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Webkitgtk Webkitgtk, Wpewebkit Wpe Webkit.

How do I fix CVE-2020-10018?

Upgrade to a fixed version.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2020-10018 being exploited?

There is no known exploitation of CVE-2020-10018 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-10018, DSA-4641-1, GHSA-37vm-m2gx-6h3h, MGASA-2020-0144, UBUNTU-CVE-2020-10018, USN-4310-1.

Is CVE-2020-10018 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free