CVE-2020-10109 HTTP Request Smuggling in Twisted
An attacker can split HTTP requests by exploiting header precedence, potentially bypassing security controls or modifying data in Twisted Web applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10109?
CVE-2020-10109 is a critical vulnerability in Canonical Ubuntu Linux, published on 12 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Twisted Web through 19.10.0, there was an HTTP request splitting vulnerability. When presented with a content-length and a chunked encoding header, the content-length took precedence and the remainder of the request body was interpreted as a pipelined request.
Weakness: CWE-444
Which versions are affected by CVE-2020-10109?
3 open source packages ship an affected version, including twisted and Twisted. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
twisted PyPI | All versions | 20.3.0 |
twisted PyPI | All versions | 20.3.0rc1 |
Twisted PyPI | All versions | 20.3.0 |
Linux distribution packages (13)
python-Twisted SUSE:Enterprise Storage 7 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Manager Proxy 4.1 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Manager Retail Branch Server 4.1 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted SUSE:Manager Server 4.1 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted openSUSE:Leap 15.3 | All versions | 19.10.0-150200.3.15.1 |
python-Twisted openSUSE:Leap 15.4 | All versions | 19.10.0-150200.3.15.1 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Twisted Twisted.
How do I fix CVE-2020-10109?
Upgrade twisted to a fixed version for your release line: 20.3.0 or 20.3.0rc1.
Is CVE-2020-10109 being exploited?
There is no known exploitation of CVE-2020-10109 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as AZL-6820, DEBIAN-CVE-2020-10109, GHSA-p5xh-vx83-mxcj, PYSEC-2020-260, SUSE-SU-2022:2822-1, UBUNTU-CVE-2020-10109.