# CVE-2020-10109: HTTP Request Smuggling in Twisted

> An attacker can split HTTP requests by exploiting header precedence, potentially bypassing security controls or modifying data in Twisted Web applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-6820, DEBIAN-CVE-2020-10109, GHSA-p5xh-vx83-mxcj, PYSEC-2020-260, SUSE-SU-2022:2822-1, UBUNTU-CVE-2020-10109

## What is CVE-2020-10109?

CVE-2020-10109 is a critical vulnerability in Canonical Ubuntu Linux, published on 12 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Twisted Web through 19.10.0, there was an HTTP request splitting vulnerability. When presented with a content-length and a chunked encoding header, the content-length took precedence and the remainder of the request body was interpreted as a pipelined request.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2020-10109?

3 open source packages ship an affected version, including twisted and Twisted. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 20.3.0 |
| `twisted` | PyPI | All versions | 20.3.0rc1 |
| `Twisted` | PyPI | All versions | 20.3.0 |
| `python-Twisted` | SUSE:Enterprise Storage 7 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Manager Proxy 4.1 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Manager Retail Branch Server 4.1 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | SUSE:Manager Server 4.1 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | openSUSE:Leap 15.3 | All versions | 19.10.0-150200.3.15.1 |
| `python-Twisted` | openSUSE:Leap 15.4 | All versions | 19.10.0-150200.3.15.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Twisted Twisted.

## How do I fix CVE-2020-10109?

Upgrade twisted to a fixed version for your release line: 20.3.0 or 20.3.0rc1.

## Is CVE-2020-10109 being exploited?

There is no known exploitation of CVE-2020-10109 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10109 and fix it if it is affected.

What it is: CVE-2020-10109 is a critical vulnerability in Canonical Ubuntu Linux, published on 12 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10109 in the wild and no public exploit code.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 20.3.0
- twisted (PyPI): affected all versions; fixed in 20.3.0rc1
- Twisted (PyPI): affected all versions; fixed in 20.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10109/ (Markdown: https://insights.sbomify.com/CVE-2020-10109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10109
- OSV: https://osv.dev/vulnerability/CVE-2020-10109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10109/
Summaries are generated and may contain mistakes; the official description above is the record.
