CVE-2020-10187 Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper
An attacker can retrieve OAuth client secrets by requesting authorized applications in JSON format if the controller is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10187?
CVE-2020-10187 is a high-severity vulnerability in n/a, published on 4 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that allows an attacker to retrieve the client secret only intended for the OAuth application owner. After authorizing the application and allowing access, the attacker simply needs to request the list of their authorized applications in a JSON format (usually GET /oauth/authorized_applications.json). An application is vulnerable if the authorized applications controller is enabled.
Weakness: CWE-862
Which versions are affected by CVE-2020-10187?
8 open source packages ship an affected version, including doorkeeper. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
doorkeeper RubyGems | From 5.0.0 | 5.0.3 |
doorkeeper RubyGems | From 5.0.0 | 5.0.3 |
doorkeeper RubyGems | From 5.1.0 | 5.1.1 |
doorkeeper RubyGems | From 5.1.0 | 5.1.1 |
doorkeeper RubyGems | From 5.2.0 | 5.2.5 |
doorkeeper RubyGems | From 5.2.0 | 5.2.5 |
2 more packages
doorkeeper RubyGems | From 5.3.0 | 5.3.2 |
doorkeeper RubyGems | From 5.3.0 | 5.3.2 |
Products include Doorkeeper Project Doorkeeper.
How do I fix CVE-2020-10187?
Upgrade doorkeeper to a fixed version for your release line: 5.0.3, 5.1.1, 5.2.5 or 5.3.2.
Is CVE-2020-10187 being exploited?
There is no known exploitation of CVE-2020-10187 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2016-6582 Doorkeeper is vulnerable to replay attacks
- CVE-2018-1000211 Doorkeeper subject to Incorrect Permission Assignment
- CVE-2014-8144 Doorkeeper vulnerable to Cross-site Request Forgery
- CVE-2018-1000088 Doorkeeper is vulnerable to stored XSS and code execution
- CVE-2023-34246 Doorkeeper Improper Authentication vulnerability
Sources
Also known as DEBIAN-CVE-2020-10187, GHSA-j7vx-8mqj-cqp9.