# CVE-2020-10187: Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper

> An attacker can retrieve OAuth client secrets by requesting authorized applications in JSON format if the controller is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-10187, GHSA-j7vx-8mqj-cqp9

## What is CVE-2020-10187?

CVE-2020-10187 is a high-severity vulnerability in n/a, published on 4 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that allows an attacker to retrieve the client secret only intended for the OAuth application owner. After authorizing the application and allowing access, the attacker simply needs to request the list of their authorized applications in a JSON format (usually GET /oauth/authorized_applications.json). An application is vulnerable if the authorized applications controller is enabled.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2020-10187?

8 open source packages ship an affected version, including doorkeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `doorkeeper` | RubyGems | From 5.0.0 | 5.0.3 |
| `doorkeeper` | RubyGems | From 5.0.0 | 5.0.3 |
| `doorkeeper` | RubyGems | From 5.1.0 | 5.1.1 |
| `doorkeeper` | RubyGems | From 5.1.0 | 5.1.1 |
| `doorkeeper` | RubyGems | From 5.2.0 | 5.2.5 |
| `doorkeeper` | RubyGems | From 5.2.0 | 5.2.5 |
| `doorkeeper` | RubyGems | From 5.3.0 | 5.3.2 |
| `doorkeeper` | RubyGems | From 5.3.0 | 5.3.2 |

Products: Doorkeeper Project Doorkeeper.

## How do I fix CVE-2020-10187?

Upgrade doorkeeper to a fixed version for your release line: 5.0.3, 5.1.1, 5.2.5 or 5.3.2.

## Is CVE-2020-10187 being exploited?

There is no known exploitation of CVE-2020-10187 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-6582](https://insights.sbomify.com/CVE-2016-6582/): Doorkeeper is vulnerable to replay attacks (critical 9.1)
- [CVE-2018-1000211](https://insights.sbomify.com/CVE-2018-1000211/): Doorkeeper subject to Incorrect Permission Assignment (high 7.5)
- [CVE-2014-8144](https://insights.sbomify.com/CVE-2014-8144/): Doorkeeper vulnerable to Cross-site Request Forgery (medium 6.8)
- [CVE-2018-1000088](https://insights.sbomify.com/CVE-2018-1000088/): Doorkeeper is vulnerable to stored XSS and code execution (medium 6.1)
- [CVE-2023-34246](https://insights.sbomify.com/CVE-2023-34246/): Doorkeeper Improper Authentication vulnerability (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10187 and fix it if it is affected.

What it is: CVE-2020-10187 is a high-severity vulnerability in n/a, published on 4 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10187 in the wild and no public exploit code.

Affected packages and fixed versions:
- doorkeeper (RubyGems): affected from 5.0.0; fixed in 5.0.3
- doorkeeper (RubyGems): affected from 5.0.0; fixed in 5.0.3
- doorkeeper (RubyGems): affected from 5.1.0; fixed in 5.1.1
- doorkeeper (RubyGems): affected from 5.1.0; fixed in 5.1.1
- doorkeeper (RubyGems): affected from 5.2.0; fixed in 5.2.5
- doorkeeper (RubyGems): affected from 5.2.0; fixed in 5.2.5
- doorkeeper (RubyGems): affected from 5.3.0; fixed in 5.3.2
- doorkeeper (RubyGems): affected from 5.3.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10187/ (Markdown: https://insights.sbomify.com/CVE-2020-10187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10187
- OSV: https://osv.dev/vulnerability/CVE-2020-10187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10187/
Summaries are generated and may contain mistakes; the official description above is the record.
