# CVE-2020-10203: Persistent Cross-Site scripting in Nexus Repository Manager

> Cross-site scripting vulnerability in Sonatype Nexus Repository allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3944-787c-f852

## What is CVE-2020-10203?

CVE-2020-10203 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Apr 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Sonatype Nexus Repository before 3.21.2 allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-10203?

2 open source packages ship an affected version, including org.sonatype.nexus:nexus-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.sonatype.nexus:nexus-core` | Maven | All versions | 3.21.2 |
| `org.sonatype.nexus:nexus-core` | Maven | All versions | 3.21.2 |

Products: Sonatype Nexus.

## How do I fix CVE-2020-10203?

Upgrade org.sonatype.nexus:nexus-core to 3.21.2 or later.

## Is CVE-2020-10203 being exploited?

There is no known exploitation of CVE-2020-10203 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-10199](https://insights.sbomify.com/CVE-2020-10199/): Sonatype Nexus Repository Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2020-11444](https://insights.sbomify.com/CVE-2020-11444/): Missing authorization in n/a (high 8.8)
- [CVE-2014-9389](https://insights.sbomify.com/CVE-2014-9389/): Path traversal in n/a (high 7.5)
- [CVE-2014-2034](https://insights.sbomify.com/CVE-2014-2034/): Auth bypass in n/a (high 7.5)
- [CVE-2014-0792](https://insights.sbomify.com/CVE-2014-0792/): Deserialization in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10203 and fix it if it is affected.

What it is: CVE-2020-10203 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Apr 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10203 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.sonatype.nexus:nexus-core (Maven): affected all versions; fixed in 3.21.2
- org.sonatype.nexus:nexus-core (Maven): affected all versions; fixed in 3.21.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10203/ (Markdown: https://insights.sbomify.com/CVE-2020-10203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10203
- OSV: https://osv.dev/vulnerability/CVE-2020-10203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10203/
Summaries are generated and may contain mistakes; the official description above is the record.
