CVE-2020-10516 Improper access control in GitHub Enterprise Server leading to privilege escalation of organization member

Critical 9.8 Published Updated

An organization member can escalate permissions to access unauthorized repositories within the organization via the API.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2020-10516?

CVE-2020-10516 is a critical vulnerability in GitHub Enterprise Server, published on 3 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An improper access control vulnerability was identified in the GitHub Enterprise Server API that allowed an organization member to escalate permissions and gain access to unauthorized repositories within an organization. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.21 and was fixed in 2.20.9, 2.19.15, and 2.18.20. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-552, CWE-285

Which versions are affected by CVE-2020-10516?

It affects 1 product.

Products include Github Github.

How do I fix CVE-2020-10516?

No fix has been published for CVE-2020-10516 yet. Limit exposure of the affected software until one is available.

Is CVE-2020-10516 being exploited?

There is no known exploitation of CVE-2020-10516 in the wild and no public exploit code.

Sources

Also known as GHSA-f436-2f67-fg74.

Is CVE-2020-10516 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free