# CVE-2020-10517: Improper access control in GitHub Enterprise Server leading to the enumeration of private repository names

> Authenticated users can enumerate private repository names via numerical IDs, exposing sensitive metadata without accessing content.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-38rx-7wc7-6jvw

## What is CVE-2020-10517?

CVE-2020-10517 is a medium-severity vulnerability in GitHub Enterprise Server, published on 27 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper access control vulnerability was identified in GitHub Enterprise Server that allowed authenticated users of the instance to determine the names of unauthorized private repositories given their numerical IDs. This vulnerability did not allow unauthorized access to any repository content besides the name. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.22 and was fixed in versions 2.21.6, 2.20.15, and 2.19.21. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-10517?

It affects 1 product.


Products: Github Github.

## How do I fix CVE-2020-10517?

No fix has been published for CVE-2020-10517 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-10517 being exploited?

There is no known exploitation of CVE-2020-10517 in the wild and no public exploit code.

## Other vulnerabilities in GitHub Enterprise Server

- [CVE-2020-10516](https://insights.sbomify.com/CVE-2020-10516/): Improper access control in GitHub Enterprise Server leading to privilege escalation of organization member (critical 9.8)
- [CVE-2017-18365](https://insights.sbomify.com/CVE-2017-18365/): Deserialization in n/a (critical 9.8)
- [CVE-2020-10519](https://insights.sbomify.com/CVE-2020-10519/): Unsafe configuration options in GitHub Pages leading to remote code execution on GitHub Enterprise Server (high 8.8)
- [CVE-2020-10518](https://insights.sbomify.com/CVE-2020-10518/): Unsafe configuration options in GitHub Pages leading to remote code execution on GitHub Enterprise Server (high 8.8)
- [CVE-2021-22863](https://insights.sbomify.com/CVE-2021-22863/): Missing authorization in GitHub Enterprise Server (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10517 and fix it if it is affected.

What it is: CVE-2020-10517 is a medium-severity vulnerability in GitHub Enterprise Server, published on 27 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10517 in the wild and no public exploit code.

Affected product: GitHub Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10517/ (Markdown: https://insights.sbomify.com/CVE-2020-10517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10517
- OSV: https://osv.dev/vulnerability/CVE-2020-10517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10517/
Summaries are generated and may contain mistakes; the official description above is the record.
