# CVE-2020-10534: Privilege escalation in n/a

> Blocked users can regain escalated privileges due to flawed IP range evaluation in the GlobalBlocking extension when an IP is in multiple ranges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2020-10534, GHSA-rmqj-6c77-6qch

## What is CVE-2020-10534?

CVE-2020-10534 is a critical vulnerability in Mediawiki Mediawiki, published on 12 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the GlobalBlocking extension before 2020-03-10 for MediaWiki through 1.34.0, an issue related to IP range evaluation resulted in blocked users re-gaining escalated privileges. This is related to the case in which an IP address is contained in two ranges, one of which is locally disabled.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-10534?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.34.1 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2020-10534?

Upgrade mediawiki to 1.34.1 or later.

## Is CVE-2020-10534 being exploited?

There is no known exploitation of CVE-2020-10534 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10534 and fix it if it is affected.

What it is: CVE-2020-10534 is a critical vulnerability in Mediawiki Mediawiki, published on 12 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10534 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.34.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10534/ (Markdown: https://insights.sbomify.com/CVE-2020-10534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10534
- OSV: https://osv.dev/vulnerability/CVE-2020-10534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10534/
Summaries are generated and may contain mistakes; the official description above is the record.
