# CVE-2020-10544: Cross-site Scripting in PrimeFaces

> Attackers can inject JavaScript via unvalidated tooltip input in PrimeFaces, leading to cross-site scripting attacks in web applications.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fw5f-7c6c-3vmv

## What is CVE-2020-10544?

CVE-2020-10544 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSS issue was discovered in tooltip/tooltip.js in PrimeTek PrimeFaces 7.0.11. In a web application using PrimeFaces, an attacker can provide JavaScript code in an input field whose data is later used as a tooltip title without any input validation.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-10544?

4 open source packages ship an affected version, including org.primefaces:primefaces and primefaces. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.primefaces:primefaces` | Maven | All versions | 8.0 |
| `org.primefaces:primefaces` | Maven | All versions | 8.0 |
| `primefaces` | npm | All versions | 8.0 |
| `primefaces` | npm | All versions | 8.0 |

Products: Primetek Primefaces.

## How do I fix CVE-2020-10544?

Upgrade org.primefaces:primefaces to 8.0 or later.

## Is CVE-2020-10544 being exploited?

There is no known exploitation of CVE-2020-10544 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-1000486](https://insights.sbomify.com/CVE-2017-1000486/): Primetek Primefaces Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10544 and fix it if it is affected.

What it is: CVE-2020-10544 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10544 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.primefaces:primefaces (Maven): affected all versions; fixed in 8.0
- org.primefaces:primefaces (Maven): affected all versions; fixed in 8.0
- primefaces (npm): affected all versions; fixed in 8.0
- primefaces (npm): affected all versions; fixed in 8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10544/ (Markdown: https://insights.sbomify.com/CVE-2020-10544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10544
- OSV: https://osv.dev/vulnerability/CVE-2020-10544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10544/
Summaries are generated and may contain mistakes; the official description above is the record.
