CVE-2020-10571 Potential buffer overflow in psd-tools
Critical 9.8
Published
Updated
Check this codebase for CVE-2020-10571 and fix it if it is affected.
What it is: CVE-2020-10571 is a critical vulnerability in n/a, published on 14 Mar 2020.
Exploitation: There is no known exploitation of CVE-2020-10571 in the wild and no public exploit code.
Affected packages and fixed versions:
- psd-tools (PyPI): affected all versions; fixed in 1.9.4
- psd-tools (PyPI): affected from 1.8.37; fixed in 1.9.4
- psd-tools (PyPI): affected from 1.8.37; fixed in 1.9.4
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2020-10571/ (Markdown: https://insights.sbomify.com/CVE-2020-10571/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2020-10571?
CVE-2020-10571 is a critical vulnerability in n/a, published on 14 Mar 2020.
Official description
An issue was discovered in psd-tools before 1.9.4. The Cython implementation of RLE decoding did not check for malicious data.
Weakness: CWE-754
Which versions are affected by CVE-2020-10571?
3 open source packages ship an affected version, including psd-tools. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
psd-tools PyPI | All versions | 1.9.4 |
psd-tools PyPI | From 1.8.37 | 1.9.4 |
psd-tools PyPI | From 1.8.37 | 1.9.4 |
Products include Psd-Tools Project Psd-Tools.
How do I fix CVE-2020-10571?
Upgrade psd-tools to 1.9.4 or later.
Is CVE-2020-10571 being exploited?
There is no known exploitation of CVE-2020-10571 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-22jr-vc7j-g762, PYSEC-2020-91.