CVE-2020-10683 dom4j allows External Entities by default which might enable XXE attacks
An attacker can exploit XML External Entity vulnerabilities in dom4j to read sensitive files or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10683?
CVE-2020-10683 is a critical vulnerability in Canonical Ubuntu Linux, published on 1 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
dom4j before 2.0.3 and 2.1.x before 2.1.3 allows external DTDs and External Entities by default, which might enable XXE attacks. However, there is popular external documentation from OWASP showing how to enable the safe, non-default behavior in any application that uses dom4j.
Weakness: CWE-611
Which versions are affected by CVE-2020-10683?
6 open source packages ship an affected version, including org.dom4j:dom4j and dom4j:dom4j. It affects 38 products.
| Package | Affected | Fixed in |
|---|---|---|
org.dom4j:dom4j Maven | All versions | 2.0.3 |
org.dom4j:dom4j Maven | All versions | 2.0.3 |
org.dom4j:dom4j Maven | From 2.1.0 | 2.1.3 |
org.dom4j:dom4j Maven | From 2.1.0 | 2.1.3 |
dom4j:dom4j Maven | All versions to 1.6.1 | None |
dom4j:dom4j Maven | All versions to 1.6.1 | None |
Linux distribution packages (3)
dom4j SUSE:Manager Server 3.2 | All versions | 1.6.1-27.7.2 |
dom4j SUSE:Manager Server Module 4.0 | All versions | 1.6.1-4.9.4 |
dom4j openSUSE:Leap 15.1 | All versions | 1.6.1-lp151.6.3.1 |
Products include Canonical Ubuntu Linux, Dom4j Project Dom4j, Netapp Oncommand Api Services, Netapp Oncommand Workflow Automation, Netapp Snap Creator Framework, Netapp Snapcenter and 32 more.
How do I fix CVE-2020-10683?
Upgrade org.dom4j:dom4j to a fixed version for your release line: 2.0.3 or 2.1.3.
Is CVE-2020-10683 being exploited?
There is no known exploitation of CVE-2020-10683 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2020-10683, DLA-2191-1, GHSA-hwj3-m3p6-hj38, MGASA-2021-0034, ROOT-APP-MAVEN-CVE-2020-10683, SUSE-SU-2020:1382-1 and 4 more.