# CVE-2020-10683: dom4j allows External Entities by default which might enable XXE attacks

> An attacker can exploit XML External Entity vulnerabilities in dom4j to read sensitive files or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-10683, DLA-2191-1, GHSA-hwj3-m3p6-hj38, MGASA-2021-0034, ROOT-APP-MAVEN-CVE-2020-10683, SUSE-SU-2020:1382-1, SUSE-SU-2020:1383-1, UBUNTU-CVE-2020-10683, USN-4575-1, openSUSE-SU-2020:0719-1

## What is CVE-2020-10683?

CVE-2020-10683 is a critical vulnerability in Canonical Ubuntu Linux, published on 1 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dom4j before 2.0.3 and 2.1.x before 2.1.3 allows external DTDs and External Entities by default, which might enable XXE attacks. However, there is popular external documentation from OWASP showing how to enable the safe, non-default behavior in any application that uses dom4j.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2020-10683?

6 open source packages ship an affected version, including org.dom4j:dom4j and dom4j:dom4j. It affects 38 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dom4j:dom4j` | Maven | All versions | 2.0.3 |
| `org.dom4j:dom4j` | Maven | All versions | 2.0.3 |
| `org.dom4j:dom4j` | Maven | From 2.1.0 | 2.1.3 |
| `org.dom4j:dom4j` | Maven | From 2.1.0 | 2.1.3 |
| `dom4j:dom4j` | Maven | All versions to 1.6.1 | None |
| `dom4j:dom4j` | Maven | All versions to 1.6.1 | None |
| `dom4j` | SUSE:Manager Server 3.2 | All versions | 1.6.1-27.7.2 |
| `dom4j` | SUSE:Manager Server Module 4.0 | All versions | 1.6.1-4.9.4 |
| `dom4j` | openSUSE:Leap 15.1 | All versions | 1.6.1-lp151.6.3.1 |

Products: Canonical Ubuntu Linux, Dom4j Project Dom4j, Netapp Oncommand Api Services, Netapp Oncommand Workflow Automation, Netapp Snap Creator Framework, Netapp Snapcenter, Netapp Snapmanager, Opensuse Leap, Oracle Agile Product Lifecycle Management, Oracle Application Testing Suite, Oracle Banking Platform, Oracle Business Process Management Suite, Oracle Communications Application Session Controller, Oracle Communications Diameter Signaling Router, Oracle Communications Unified Inventory Management, Oracle Data Integrator, Oracle Documaker, Oracle Endeca Information Discovery Integrator, Oracle Enterprise Data Quality, Oracle Enterprise Manager Base Platform and 18 more.

## How do I fix CVE-2020-10683?

Upgrade org.dom4j:dom4j to a fixed version for your release line: 2.0.3 or 2.1.3.

## Is CVE-2020-10683 being exploited?

There is no known exploitation of CVE-2020-10683 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10683 and fix it if it is affected.

What it is: CVE-2020-10683 is a critical vulnerability in Canonical Ubuntu Linux, published on 1 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10683 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dom4j:dom4j (Maven): affected all versions; fixed in 2.0.3
- org.dom4j:dom4j (Maven): affected all versions; fixed in 2.0.3
- org.dom4j:dom4j (Maven): affected from 2.1.0; fixed in 2.1.3
- org.dom4j:dom4j (Maven): affected from 2.1.0; fixed in 2.1.3
- dom4j:dom4j (Maven): affected all versions up to 1.6.1; no fix listed
- dom4j:dom4j (Maven): affected all versions up to 1.6.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10683/ (Markdown: https://insights.sbomify.com/CVE-2020-10683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10683
- OSV: https://osv.dev/vulnerability/CVE-2020-10683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10683/
Summaries are generated and may contain mistakes; the official description above is the record.
