# CVE-2020-10684: Code Injection, Race Condition, and Execution with Unnecessary Privileges in Ansible

> Attackers can inject code or escalate privileges by manipulating ansible_facts when variable injection is enabled in Ansible Engine.

- **Severity:** High 7.9 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-10684, GHSA-p62g-jhg6-v3rq, PYSEC-2020-207, UBUNTU-CVE-2020-10684

## What is CVE-2020-10684?

CVE-2020-10684 is a high-severity code injection vulnerability in Debian Debian Linux, published on 24 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-862 (Missing Authorization), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2020-10684?

7 open source packages ship an affected version, including ansible. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.7.0 | 2.7.17, 2.8.9, 2.9.6 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.17 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.17 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.11 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.11 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |

Products: Debian Debian Linux, Fedoraproject Fedora, Redhat Ansible, Redhat Ansible Tower, Redhat Openstack.

## How do I fix CVE-2020-10684?

Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.9, 2.9.6 or 2.8.11.

## Is CVE-2020-10684 being exploited?

There is no known exploitation of CVE-2020-10684 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10684 and fix it if it is affected.

What it is: CVE-2020-10684 is a high-severity code injection vulnerability in Debian Debian Linux, published on 24 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10684 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.7.0; fixed in 2.7.17, 2.8.9, 2.9.6
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.17
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.17
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.11
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.11
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10684/ (Markdown: https://insights.sbomify.com/CVE-2020-10684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10684
- OSV: https://osv.dev/vulnerability/CVE-2020-10684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10684/
Summaries are generated and may contain mistakes; the official description above is the record.
