CVE-2020-10685 Exposure of Resource to Wrong Sphere and Insecure Temporary File in Ansible
Ansible leaves decrypted vault files in /tmp, allowing local attackers to read sensitive data if the system is powered off.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-10685?
CVE-2020-10685 is a medium-severity vulnerability in Debian Debian Linux, published on 11 May 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
A flaw was found in Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when using modules which decrypts vault files such as assemble, script, unarchive, win_copy, aws_s3 or copy modules. The temporary directory is created in /tmp leaves the s ts unencrypted. On Operating Systems which /tmp is not a tmpfs but part of the root partition, the directory is only cleared on boot and the decryp emains when the host is switched off. The system will be vulnerable when the system is not running. So decrypted data must be cleared as soon as possible and the data which normally is encrypted ble.
Weakness: CWE-459
Which versions are affected by CVE-2020-10685?
7 open source packages ship an affected version, including ansible. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | From 2.7.0 | 2.7.17, 2.8.11, 2.9.7 |
ansible PyPI | From 2.7.0a1 | 2.7.17 |
ansible PyPI | From 2.7.0a1 | 2.7.17 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.9.0a1 | 2.9.7 |
1 more packages
ansible PyPI | From 2.9.0a1 | 2.9.7 |
Products include Debian Debian Linux, Redhat Ansible Engine, Redhat Ansible Tower, Redhat Ceph Storage, Redhat Openstack, Redhat Storage.
How do I fix CVE-2020-10685?
Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.11 or 2.9.7.
Is CVE-2020-10685 being exploited?
There is no known exploitation of CVE-2020-10685 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2020-10685, GHSA-77g3-3j5w-64w4, OESA-2025-2065, PYSEC-2020-1, UBUNTU-CVE-2020-10685.