# CVE-2020-10685: Exposure of Resource to Wrong Sphere and Insecure Temporary File in Ansible

> Ansible leaves decrypted vault files in /tmp, allowing local attackers to read sensitive data if the system is powered off.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-10685, GHSA-77g3-3j5w-64w4, OESA-2025-2065, PYSEC-2020-1, UBUNTU-CVE-2020-10685

## What is CVE-2020-10685?

CVE-2020-10685 is a medium-severity vulnerability in Debian Debian Linux, published on 11 May 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when using modules which decrypts vault files such as assemble, script, unarchive, win_copy, aws_s3 or copy modules. The temporary directory is created in /tmp leaves the s ts unencrypted. On Operating Systems which /tmp is not a tmpfs but part of the root partition, the directory is only cleared on boot and the decryp emains when the host is switched off. The system will be vulnerable when the system is not running. So decrypted data must be cleared as soon as possible and the data which normally is encrypted ble.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2020-10685?

7 open source packages ship an affected version, including ansible. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.7.0 | 2.7.17, 2.8.11, 2.9.7 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.17 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.17 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.11 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.11 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |

Products: Debian Debian Linux, Redhat Ansible Engine, Redhat Ansible Tower, Redhat Ceph Storage, Redhat Openstack, Redhat Storage.

## How do I fix CVE-2020-10685?

Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.11 or 2.9.7.

## Is CVE-2020-10685 being exploited?

There is no known exploitation of CVE-2020-10685 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10685 and fix it if it is affected.

What it is: CVE-2020-10685 is a medium-severity vulnerability in Debian Debian Linux, published on 11 May 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10685 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.7.0; fixed in 2.7.17, 2.8.11, 2.9.7
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.17
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.17
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.11
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.11
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10685/ (Markdown: https://insights.sbomify.com/CVE-2020-10685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10685
- OSV: https://osv.dev/vulnerability/CVE-2020-10685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10685/
Summaries are generated and may contain mistakes; the official description above is the record.
