CVE-2020-10688 Cross-site scripting in RESTEasy
An attacker can execute arbitrary scripts in a victim's browser via reflected XSS in RESTEasy when handling specific URL encoding errors.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-10688?
CVE-2020-10688 is a medium-severity cross-site scripting vulnerability in Redhat Jboss Enterprise Application Platform, published on 27 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A cross-site scripting (XSS) flaw was found in RESTEasy in versions before 3.11.1.Final and before 4.5.3.Final, where it did not properly handle URL encoding when the RESTEASY003870 exception occurs. An attacker could use this flaw to launch a reflected XSS attack.
Weakness: CWE-79
Which versions are affected by CVE-2020-10688?
8 open source packages ship an affected version, including org.jboss.resteasy:resteasy-bom and org.jboss.resteasy:resteasy-core. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jboss.resteasy:resteasy-bom Maven | All versions | 3.11.1.Final |
org.jboss.resteasy:resteasy-bom Maven | All versions | 3.11.1.Final |
org.jboss.resteasy:resteasy-bom Maven | From 4.0.0 | 4.5.3.Final |
org.jboss.resteasy:resteasy-bom Maven | From 4.0.0 | 4.5.3.Final |
org.jboss.resteasy:resteasy-core Maven | All versions | 3.11.1.Final |
org.jboss.resteasy:resteasy-core Maven | All versions | 3.11.1.Final |
2 more packages
org.jboss.resteasy:resteasy-core Maven | From 4.0.0 | 4.5.3.Final |
org.jboss.resteasy:resteasy-core Maven | From 4.0.0 | 4.5.3.Final |
Products include Redhat Fuse, Redhat Jboss Enterprise Application Platform, Redhat Openshift Application Runtimes, Redhat Resteasy.
How do I fix CVE-2020-10688?
Upgrade org.jboss.resteasy:resteasy-bom to a fixed version for your release line: 3.11.1.Final or 4.5.3.Final.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-10688 being exploited?
There is no known exploitation of CVE-2020-10688 in the wild and no public exploit code.
Other vulnerabilities in Redhat Jboss Enterprise Application Platform
- CVE-2026-41731 In Spring for Apache Kafka, overly broad trusted-package matching in header mappers exposes JDK classes to deserialization
- CVE-2021-3690 Undertow vulnerable to memory exhaustion due to buffer leak
- CVE-2019-14860 Misconfiguration in syndesis
- CVE-2025-57849 Fuse: privilege escalation via excessive /etc/passwd permissions
All Redhat Jboss Enterprise Application Platform vulnerabilities
Sources
Also known as DEBIAN-CVE-2020-10688, GHSA-29qj-rvv6-qrmv, OESA-2021-1231, UBUNTU-CVE-2020-10688.