# CVE-2020-10688: Cross-site scripting in RESTEasy

> An attacker can execute arbitrary scripts in a victim's browser via reflected XSS in RESTEasy when handling specific URL encoding errors.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 May 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-10688, GHSA-29qj-rvv6-qrmv, OESA-2021-1231, UBUNTU-CVE-2020-10688

## What is CVE-2020-10688?

CVE-2020-10688 is a medium-severity cross-site scripting vulnerability in Redhat Jboss Enterprise Application Platform, published on 27 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting (XSS) flaw was found in RESTEasy in versions before 3.11.1.Final and before 4.5.3.Final, where it did not properly handle URL encoding when the RESTEASY003870 exception occurs. An attacker could use this flaw to launch a reflected XSS attack.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-10688?

8 open source packages ship an affected version, including org.jboss.resteasy:resteasy-bom and org.jboss.resteasy:resteasy-core. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.resteasy:resteasy-bom` | Maven | All versions | 3.11.1.Final |
| `org.jboss.resteasy:resteasy-bom` | Maven | All versions | 3.11.1.Final |
| `org.jboss.resteasy:resteasy-bom` | Maven | From 4.0.0 | 4.5.3.Final |
| `org.jboss.resteasy:resteasy-bom` | Maven | From 4.0.0 | 4.5.3.Final |
| `org.jboss.resteasy:resteasy-core` | Maven | All versions | 3.11.1.Final |
| `org.jboss.resteasy:resteasy-core` | Maven | All versions | 3.11.1.Final |
| `org.jboss.resteasy:resteasy-core` | Maven | From 4.0.0 | 4.5.3.Final |
| `org.jboss.resteasy:resteasy-core` | Maven | From 4.0.0 | 4.5.3.Final |

Products: Redhat Fuse, Redhat Jboss Enterprise Application Platform, Redhat Openshift Application Runtimes, Redhat Resteasy.

## How do I fix CVE-2020-10688?

Upgrade org.jboss.resteasy:resteasy-bom to a fixed version for your release line: 3.11.1.Final or 4.5.3.Final.

## Is CVE-2020-10688 being exploited?

There is no known exploitation of CVE-2020-10688 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2026-41731](https://insights.sbomify.com/CVE-2026-41731/): In Spring for Apache Kafka, overly broad trusted-package matching in header mappers exposes JDK classes to deserialization (high 8.1)
- [CVE-2021-3690](https://insights.sbomify.com/CVE-2021-3690/): Undertow vulnerable to memory exhaustion due to buffer leak (high 7.5)
- [CVE-2019-14860](https://insights.sbomify.com/CVE-2019-14860/): Misconfiguration in syndesis (high 7.4)
- [CVE-2025-57849](https://insights.sbomify.com/CVE-2025-57849/): Fuse: privilege escalation via excessive /etc/passwd permissions (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10688 and fix it if it is affected.

What it is: CVE-2020-10688 is a medium-severity cross-site scripting vulnerability in Redhat Jboss Enterprise Application Platform, published on 27 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10688 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.resteasy:resteasy-bom (Maven): affected all versions; fixed in 3.11.1.Final
- org.jboss.resteasy:resteasy-bom (Maven): affected all versions; fixed in 3.11.1.Final
- org.jboss.resteasy:resteasy-bom (Maven): affected from 4.0.0; fixed in 4.5.3.Final
- org.jboss.resteasy:resteasy-bom (Maven): affected from 4.0.0; fixed in 4.5.3.Final
- org.jboss.resteasy:resteasy-core (Maven): affected all versions; fixed in 3.11.1.Final
- org.jboss.resteasy:resteasy-core (Maven): affected all versions; fixed in 3.11.1.Final
- org.jboss.resteasy:resteasy-core (Maven): affected from 4.0.0; fixed in 4.5.3.Final
- org.jboss.resteasy:resteasy-core (Maven): affected from 4.0.0; fixed in 4.5.3.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10688/ (Markdown: https://insights.sbomify.com/CVE-2020-10688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10688
- OSV: https://osv.dev/vulnerability/CVE-2020-10688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10688/
Summaries are generated and may contain mistakes; the official description above is the record.
