CVE-2020-10691 Path Traversal in Ansible
Attackers can overwrite arbitrary system files via path traversal in Ansible Galaxy collection installation, requiring an upgrade to Ansible Engine.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10691?
CVE-2020-10691 is a medium-severity path traversal vulnerability in Redhat Ansible Tower, published on 30 Apr 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install. When extracting a collection .tar.gz file, the directory is created without sanitizing the filename. An attacker could take advantage to overwrite any file within the system.
Weakness: CWE-22
Which versions are affected by CVE-2020-10691?
3 open source packages ship an affected version, including ansible. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | From 2.9.0 | 2.9.7 |
ansible PyPI | From 2.9.0a1 | 2.9.7 |
ansible PyPI | From 2.9.0a1 | 2.9.7 |
Products include Redhat Ansible Engine, Redhat Ansible Tower.
How do I fix CVE-2020-10691?
Upgrade ansible to 2.9.7 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2020-10691 being exploited?
There is no known exploitation of CVE-2020-10691 in the wild and no public exploit code.
Other vulnerabilities in Redhat Ansible Tower
Sources
Also known as ALPINE-CVE-2020-10691, DEBIAN-CVE-2020-10691, GHSA-3c67-gc48-983w, PYSEC-2020-2, UBUNTU-CVE-2020-10691.