{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-10691 in the wild and no public exploit code.","fix":"Upgrade ansible to 2.9.7 or later.","what":"CVE-2020-10691 is a medium-severity path traversal vulnerability in Redhat Ansible Tower, published on 30 Apr 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-10691 and fix it if it is affected.\n\nWhat it is: CVE-2020-10691 is a medium-severity path traversal vulnerability in Redhat Ansible Tower, published on 30 Apr 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-10691 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected from 2.9.0; fixed in 2.9.7\n- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7\n- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-10691/ (Markdown: https://insights.sbomify.com/CVE-2020-10691/index.md)","id":"CVE-2020-10691","markdown":"https://insights.sbomify.com/CVE-2020-10691/index.md","name":"CVE-2020-10691","record":{"aliases":["ALPINE-CVE-2020-10691","DEBIAN-CVE-2020-10691","GHSA-3c67-gc48-983w","PYSEC-2020-2","UBUNTU-CVE-2020-10691"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible Galaxy","requires_auth":"low_privilege","summary":"Attackers can overwrite arbitrary system files via path traversal in Ansible Galaxy collection installation, requiring an upgrade to Ansible Engine.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible_engine","vendor":"redhat"},{"product":"ansible_tower","vendor":"redhat"}],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install. When extracting a collection .tar.gz file, the directory is created without sanitizing the filename. An attacker could take advantage to overwrite any file within the system.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal in Ansible","id":"CVE-2020-10691","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:ansible_tower","products":["redhat:ansible_tower"],"type":"path_traversal","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2020-10692"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.7"],"introduced":["2.9.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2020-2"},{"ecosystem":"PyPI","fixed":["2.9.7"],"introduced":["2.9.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-3c67-gc48-983w"},{"ecosystem":"PyPI","fixed":["2.9.7"],"introduced":["2.9.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-3c67-gc48-983w"}],"prev":{"headline":"Use after free in kernel","id":"CVE-2020-10690"},"products":["Ansible"],"published":"2020-04-30","related":[{"cvss_score":7.8,"headline":"Ansible Improper Input Validation vulnerability","id":"CVE-2018-10874","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":7.5,"headline":"Path Traversal in Ansible","id":"CVE-2020-1737","kev_date_added":null,"published":"2020-03-09"},{"cvss_score":7.4,"headline":"OS Command Injection in ansible","id":"CVE-2020-1734","kev_date_added":null,"published":"2020-03-03"},{"cvss_score":7.3,"headline":"Ansible leaks sensitive information to logs when told not to","id":"CVE-2019-14858","kev_date_added":null,"published":"2019-10-14"},{"cvss_score":4.2,"headline":"Ansible Logs Passwords If PowerShell ScriptBlock is Enabled","id":"CVE-2018-16859","kev_date_added":null,"published":"2018-11-29"},{"cvss_score":2.2,"headline":"Improper Input Validation in ansible","id":"CVE-2016-8647","kev_date_added":null,"published":"2018-07-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Red Hat"]},"summary":"Attackers can overwrite arbitrary system files via path traversal in Ansible Galaxy collection installation, requiring an upgrade to Ansible Engine.","url":"https://insights.sbomify.com/CVE-2020-10691/"}