# CVE-2020-10691: Path Traversal in Ansible

> Attackers can overwrite arbitrary system files via path traversal in Ansible Galaxy collection installation, requiring an upgrade to Ansible Engine.

- **Severity:** Medium 5.2 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-10691, DEBIAN-CVE-2020-10691, GHSA-3c67-gc48-983w, PYSEC-2020-2, UBUNTU-CVE-2020-10691

## What is CVE-2020-10691?

CVE-2020-10691 is a medium-severity path traversal vulnerability in Redhat Ansible Tower, published on 30 Apr 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install. When extracting a collection .tar.gz file, the directory is created without sanitizing the filename. An attacker could take advantage to overwrite any file within the system.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-10691?

3 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.9.0 | 2.9.7 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |

Products: Redhat Ansible Engine, Redhat Ansible Tower.

## How do I fix CVE-2020-10691?

Upgrade ansible to 2.9.7 or later.

## Is CVE-2020-10691 being exploited?

There is no known exploitation of CVE-2020-10691 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Ansible Tower

- [CVE-2018-10874](https://insights.sbomify.com/CVE-2018-10874/): Ansible Improper Input Validation vulnerability (high 7.8)
- [CVE-2020-1737](https://insights.sbomify.com/CVE-2020-1737/): Path Traversal in Ansible (high 7.5)
- [CVE-2020-1734](https://insights.sbomify.com/CVE-2020-1734/): OS Command Injection in ansible (high 7.4)
- [CVE-2019-14858](https://insights.sbomify.com/CVE-2019-14858/): Ansible leaks sensitive information to logs when told not to (high 7.3)
- [CVE-2018-16859](https://insights.sbomify.com/CVE-2018-16859/): Ansible Logs Passwords If PowerShell ScriptBlock is Enabled (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10691 and fix it if it is affected.

What it is: CVE-2020-10691 is a medium-severity path traversal vulnerability in Redhat Ansible Tower, published on 30 Apr 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10691 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.9.0; fixed in 2.9.7
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10691/ (Markdown: https://insights.sbomify.com/CVE-2020-10691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10691
- OSV: https://osv.dev/vulnerability/CVE-2020-10691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10691/
Summaries are generated and may contain mistakes; the official description above is the record.
