{"answers":{"affected":"2 open source packages ship an affected version, including io.fabric8:fabric8-maven-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-10721 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-10721 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-10721 is a high-severity unsafe deserialization vulnerability in fabric8-maven-plugin, published on 22 Oct 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-10721 and fix it if it is affected.\n\nWhat it is: CVE-2020-10721 is a high-severity unsafe deserialization vulnerability in fabric8-maven-plugin, published on 22 Oct 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-10721 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.fabric8:fabric8-maven-plugin (Maven): affected from 4.0.0-M1 up to 4.4.2; no fix listed\n- io.fabric8:fabric8-maven-plugin (Maven): affected from 4.0.0-M1 up to 4.4.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-10721/ (Markdown: https://insights.sbomify.com/CVE-2020-10721/index.md)","id":"CVE-2020-10721","markdown":"https://insights.sbomify.com/CVE-2020-10721/index.md","name":"CVE-2020-10721","record":{"aliases":["GHSA-w7gj-h6f2-x4c6"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Maven build plugin","requires_auth":"low_privilege","summary":"A malicious YAML file can trigger unsafe deserialization in the fabric8-maven-plugin, leading to arbitrary code execution on the developer's machine.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fabric8-maven","vendor":"redhat"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A flaw was found in the fabric8-maven-plugin 4.0.0 and later. When using a wildfly-swarm or thorntail custom configuration, a malicious YAML configuration file on the local machine executing the maven plug-in could allow for deserialization of untrusted data resulting in arbitrary code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"fabric8-maven-plugin: insecure way to construct Yaml Object leading to remote code execution","id":"CVE-2020-10721","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Integer overflow in dpdk","id":"CVE-2020-10722"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["4.0.0-M1"],"last_affected":["4.4.2"],"package":"io.fabric8:fabric8-maven-plugin","purl":null,"source":"GHSA-w7gj-h6f2-x4c6"},{"ecosystem":"Maven","fixed":[],"introduced":["4.0.0-M1"],"last_affected":["4.4.2"],"package":"io.fabric8:fabric8-maven-plugin","purl":"pkg:maven/io.fabric8/fabric8-maven-plugin","source":"GHSA-w7gj-h6f2-x4c6"}],"prev":{"headline":"Use after free in Kernel","id":"CVE-2020-10720"},"products":["fabric8-maven-plugin"],"published":"2020-10-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A malicious YAML file can trigger unsafe deserialization in the fabric8-maven-plugin, leading to arbitrary code execution on the developer's machine.","url":"https://insights.sbomify.com/CVE-2020-10721/"}