{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-10729 in the wild and no public exploit code.","fix":"Upgrade ansible to 2.9.6 or later.","what":"CVE-2020-10729 is a medium-severity vulnerability in Debian Debian Linux, published on 27 May 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-10729 and fix it if it is affected.\n\nWhat it is: CVE-2020-10729 is a medium-severity vulnerability in Debian Debian Linux, published on 27 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-10729 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.9.6\n- ansible (PyPI): affected all versions; fixed in 2.9.6\n- ansible (PyPI): affected all versions; fixed in 2.9.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-10729/ (Markdown: https://insights.sbomify.com/CVE-2020-10729/index.md)","id":"CVE-2020-10729","markdown":"https://insights.sbomify.com/CVE-2020-10729/index.md","name":"CVE-2020-10729","record":{"aliases":["CLSA-2025-1744709445","CLSA-2025-1744719966","DEBIAN-CVE-2020-10729","GHSA-r6h7-5pq2-j77h","PYSEC-2021-105","RHBA-2020:0784","UBUNTU-CVE-2020-10729"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"Insufficient randomness in Ansible password lookups causes cached values to be reused, potentially exposing all generated passwords for a file.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"ansible_engine","vendor":"redhat"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-330","name":"Use of Insufficiently Random Values"}],"description":"A flaw was found in the use of insufficiently random values in Ansible. Two random password lookups of the same length generate the equal value as the template caching action for the same file since no re-evaluation happens. The highest threat from this vulnerability would be that all passwords are exposed at once for the file. This flaw affects Ansible Engine versions before 2.9.6.","ecosystems":["PyPI","Red Hat:ansible_engine:2.9::el7","Red Hat:ansible_engine:2.9::el8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficiently random values in Ansible","id":"CVE-2020-10729","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"weak_cryptography","year":"2020"},"n_packages":7,"n_references":3,"next":{"headline":"Null dereference in Samba","id":"CVE-2020-10730"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.6"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-r6h7-5pq2-j77h"},{"ecosystem":"PyPI","fixed":["2.9.6"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-r6h7-5pq2-j77h"},{"ecosystem":"PyPI","fixed":["2.9.6"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2021-105"},{"ecosystem":"Red Hat:ansible_engine:2.9::el7","fixed":["0:2.9.6-1.el7ae"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:rpm/redhat/ansible","source":"RHBA-2020:0784"},{"ecosystem":"Red Hat:ansible_engine:2.9::el7","fixed":["0:2.9.6-1.el7ae"],"introduced":["0"],"last_affected":[],"package":"ansible-test","purl":"pkg:rpm/redhat/ansible-test","source":"RHBA-2020:0784"},{"ecosystem":"Red Hat:ansible_engine:2.9::el8","fixed":["0:2.9.6-1.el8ae"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:rpm/redhat/ansible","source":"RHBA-2020:0784"},{"ecosystem":"Red Hat:ansible_engine:2.9::el8","fixed":["0:2.9.6-1.el8ae"],"introduced":["0"],"last_affected":[],"package":"ansible-test","purl":"pkg:rpm/redhat/ansible-test","source":"RHBA-2020:0784"}],"prev":{"headline":"Privilege escalation in automationbroker/apb","id":"CVE-2020-10728"},"products":["Ansible"],"published":"2021-05-27","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHBA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Insufficient randomness in Ansible password lookups causes cached values to be reused, potentially exposing all generated passwords for a file.","url":"https://insights.sbomify.com/CVE-2020-10729/"}