# CVE-2020-10736: Missing authorization in ceph

> Authenticated clients can bypass authorization checks in Ceph daemons to modify configurations and potentially escalate privileges.

- **Severity:** High 8.0 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-ceph-2020-10736, GHSA-7hf6-hcxg-35gw, UBUNTU-CVE-2020-10736

## What is CVE-2020-10736?

CVE-2020-10736 is a high-severity missing authorization vulnerability in [UNKNOWN] ceph, published on 22 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An authorization bypass vulnerability was found in Ceph versions 15.2.0 before 15.2.2, where the ceph-mon and ceph-mgr daemons do not properly restrict access, resulting in gaining access to unauthorized resources. This flaw allows an authenticated client to modify the configuration and possibly conduct further attacks.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-10736?

1 open source package ship an affected version, including ceph. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ceph` | Bitnami | From 15.2.0 | 15.2.2 |

Products: Linuxfoundation Ceph.

## How do I fix CVE-2020-10736?

Upgrade ceph to 15.2.2 or later.

## Is CVE-2020-10736 being exploited?

There is no known exploitation of CVE-2020-10736 in the wild and no public exploit code.

## Other vulnerabilities in [UNKNOWN] ceph

- [CVE-2020-1699](https://insights.sbomify.com/CVE-2020-1699/): Path traversal in ceph (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10736 and fix it if it is affected.

What it is: CVE-2020-10736 is a high-severity missing authorization vulnerability in [UNKNOWN] ceph, published on 22 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10736 in the wild and no public exploit code.

Affected packages and fixed versions:
- ceph (Bitnami): affected from 15.2.0; fixed in 15.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10736/ (Markdown: https://insights.sbomify.com/CVE-2020-10736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10736
- OSV: https://osv.dev/vulnerability/CVE-2020-10736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10736/
Summaries are generated and may contain mistakes; the official description above is the record.
