CVE-2020-10738 Moodle vulnerable to RCE
Attackers can achieve remote code execution by creating malicious SCORM packages in Moodle, requiring immediate upgrades to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10738?
CVE-2020-10738 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.
Weakness: CWE-20
Which versions are affected by CVE-2020-10738?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5 | 3.5.12 |
moodle/moodle Packagist | From 3.5 | 3.5.12 |
moodle/moodle Packagist | From 3.6 | 3.6.10 |
moodle/moodle Packagist | From 3.6 | 3.6.10 |
moodle/moodle Packagist | From 3.7 | 3.7.6 |
moodle/moodle Packagist | From 3.7 | 3.7.6 |
3 more packages
moodle/moodle Packagist | From 3.8 | 3.8.3 |
moodle/moodle Packagist | From 3.8 | 3.8.3 |
moodle Bitnami | From 3.5.0 | 3.5.12, 3.6.10, 3.7.6, 3.8.3 |
Products include Moodle Moodle.
How do I fix CVE-2020-10738?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.12, 3.6.10, 3.7.6 or 3.8.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2020-10738 being exploited?
There is no known exploitation of CVE-2020-10738 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2020-10738, GHSA-vr6v-g96p-cjc3, UBUNTU-CVE-2020-10738.