{"answers":{"affected":"9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-10738 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.5.12, 3.6.10, 3.7.6 or 3.8.3.","what":"CVE-2020-10738 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 May 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-10738 and fix it if it is affected.\n\nWhat it is: CVE-2020-10738 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-10738 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.12\n- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.12\n- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.10\n- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.10\n- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.6\n- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.6\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.3\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.3\n- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.12, 3.6.10, 3.7.6, 3.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-10738/ (Markdown: https://insights.sbomify.com/CVE-2020-10738/index.md)","id":"CVE-2020-10738","markdown":"https://insights.sbomify.com/CVE-2020-10738/index.md","name":"CVE-2020-10738","record":{"aliases":["BIT-moodle-2020-10738","GHSA-vr6v-g96p-cjc3","UBUNTU-CVE-2020-10738"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution by creating malicious SCORM packages in Moodle, requiring immediate upgrades to patched versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle vulnerable to RCE","id":"CVE-2020-10738","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"code_injection","year":"2020"},"n_packages":9,"n_references":3,"next":{"headline":"Null dereference in istio/envoy","id":"CVE-2020-10739"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.12","3.6.10","3.7.6","3.8.3"],"introduced":["3.5.0","3.6.0","3.7.0","3.8.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2020-10738"},{"ecosystem":"Packagist","fixed":["3.5.12"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vr6v-g96p-cjc3"},{"ecosystem":"Packagist","fixed":["3.5.12"],"introduced":["3.5"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vr6v-g96p-cjc3"},{"ecosystem":"Packagist","fixed":["3.6.10"],"introduced":["3.6"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vr6v-g96p-cjc3"},{"ecosystem":"Packagist","fixed":["3.6.10"],"introduced":["3.6"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vr6v-g96p-cjc3"},{"ecosystem":"Packagist","fixed":["3.7.6"],"introduced":["3.7"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vr6v-g96p-cjc3"},{"ecosystem":"Packagist","fixed":["3.7.6"],"introduced":["3.7"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vr6v-g96p-cjc3"},{"ecosystem":"Packagist","fixed":["3.8.3"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vr6v-g96p-cjc3"},{"ecosystem":"Packagist","fixed":["3.8.3"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vr6v-g96p-cjc3"}],"prev":{"headline":"Race condition in oddjob","id":"CVE-2020-10737"},"products":["moodle"],"published":"2020-05-21","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["[UNKNOWN]"]},"summary":"Attackers can achieve remote code execution by creating malicious SCORM packages in Moodle, requiring immediate upgrades to patched versions.","url":"https://insights.sbomify.com/CVE-2020-10738/"}