# CVE-2020-10738: Moodle vulnerable to RCE

> Attackers can achieve remote code execution by creating malicious SCORM packages in Moodle, requiring immediate upgrades to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-moodle-2020-10738, GHSA-vr6v-g96p-cjc3, UBUNTU-CVE-2020-10738

## What is CVE-2020-10738?

CVE-2020-10738 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-10738?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.12 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.12 |
| `moodle/moodle` | Packagist | From 3.6 | 3.6.10 |
| `moodle/moodle` | Packagist | From 3.6 | 3.6.10 |
| `moodle/moodle` | Packagist | From 3.7 | 3.7.6 |
| `moodle/moodle` | Packagist | From 3.7 | 3.7.6 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.3 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.3 |
| `moodle` | Bitnami | From 3.5.0 | 3.5.12, 3.6.10, 3.7.6, 3.8.3 |

Products: Moodle Moodle.

## How do I fix CVE-2020-10738?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.12, 3.6.10, 3.7.6 or 3.8.3.

## Is CVE-2020-10738 being exploited?

There is no known exploitation of CVE-2020-10738 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10738 and fix it if it is affected.

What it is: CVE-2020-10738 is a high-severity code injection vulnerability in Moodle Moodle, published on 21 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10738 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.12
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.12
- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.10
- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.10
- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.6
- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.6
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.3
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.3
- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.12, 3.6.10, 3.7.6, 3.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10738/ (Markdown: https://insights.sbomify.com/CVE-2020-10738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10738
- OSV: https://osv.dev/vulnerability/CVE-2020-10738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10738/
Summaries are generated and may contain mistakes; the official description above is the record.
