# CVE-2020-10740: Wildfly Unsafe Deserialization Vulnerability

> Remote attackers can execute arbitrary code via unsafe deserialization in WildFly's Enterprise Application Beans due to missing input validation.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wildfly-2020-10740, GHSA-vrmw-2xhq-hrmp

## What is CVE-2020-10740?

CVE-2020-10740 is a medium-severity unsafe deserialization vulnerability in [UNKNOWN] wildfly, published on 22 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability was found in Wildfly in versions before 20.0.0.Final, where a remote deserialization attack is possible in the Enterprise Application Beans(EJB) due to lack of validation/filtering capabilities in wildfly.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-10740?

3 open source packages ship an affected version, including org.wildfly:wildfly-parent and wildfly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wildfly:wildfly-parent` | Maven | All versions | 20.0.0.Final |
| `org.wildfly:wildfly-parent` | Maven | All versions | 20.0.0.Final |
| `wildfly` | Bitnami | All versions | 20.0.0 |

Products: Redhat Wildfly.

## How do I fix CVE-2020-10740?

Upgrade org.wildfly:wildfly-parent to 20.0.0.Final or later.

## Is CVE-2020-10740 being exploited?

There is no known exploitation of CVE-2020-10740 in the wild and no public exploit code.

## Other vulnerabilities in [UNKNOWN] wildfly

- [CVE-2018-10683](https://insights.sbomify.com/CVE-2018-10683/): Auth bypass in n/a (critical 9.8)
- [CVE-2020-27822](https://insights.sbomify.com/CVE-2020-27822/): Wildfly has a memory leak vulnerability (medium 5.9)
- [CVE-2020-1719](https://insights.sbomify.com/CVE-2020-1719/): Privilege Context Switching Error in wildlfy (medium 5.4)
- [CVE-2020-25640](https://insights.sbomify.com/CVE-2020-25640/): Wildfly logs plaintext passwords (medium 5.3)
- [CVE-2018-14627](https://insights.sbomify.com/CVE-2018-14627/): Security feature bypass in JBoss/WildFly (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10740 and fix it if it is affected.

What it is: CVE-2020-10740 is a medium-severity unsafe deserialization vulnerability in [UNKNOWN] wildfly, published on 22 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10740 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wildfly:wildfly-parent (Maven): affected all versions; fixed in 20.0.0.Final
- org.wildfly:wildfly-parent (Maven): affected all versions; fixed in 20.0.0.Final
- wildfly (Bitnami): affected all versions; fixed in 20.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10740/ (Markdown: https://insights.sbomify.com/CVE-2020-10740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10740
- OSV: https://osv.dev/vulnerability/CVE-2020-10740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10740/
Summaries are generated and may contain mistakes; the official description above is the record.
