CVE-2020-10755 Openstack cinder Improper handling of ScaleIO backend credentials
Attackers can retrieve backend storage credentials via API calls, allowing unauthorized access to other users' volumes and management APIs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10755?
CVE-2020-10755 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 10 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project
Weakness: CWE-522
Which versions are affected by CVE-2020-10755?
14 open source packages ship an affected version, including cinder and os-brick. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
cinder PyPI | All versions | 14.1.0, 15.2.0, 16.1.0 |
cinder PyPI | From 14.0.0 | 14.1.0 |
cinder PyPI | From 14.0.0 | 14.1.0 |
cinder PyPI | From 15.0.0 | 15.2.0 |
cinder PyPI | From 15.0.0 | 15.2.0 |
cinder PyPI | From 16.0.0 | 16.1.0 |
8 more packages
cinder PyPI | From 16.0.0 | 16.1.0 |
os-brick PyPI | From 2.10.0 | 2.10.4 |
os-brick PyPI | From 2.10.0 | 2.10.4 |
os-brick PyPI | From 2.8.0 | 2.8.6, 2.10.4, 3.0.2 |
os-brick PyPI | From 2.8.0 | 2.8.6 |
os-brick PyPI | From 2.8.0 | 2.8.6 |
os-brick PyPI | From 3.0.0 | 3.0.2 |
os-brick PyPI | From 3.0.0 | 3.0.2 |
Linux distribution packages (4)
openstack-cinder Red Hat:openstack:13::el7 | All versions | 1:12.0.10-19.el7ost |
python-cinder Red Hat:openstack:13::el7 | All versions | 1:12.0.10-19.el7ost |
openstack-cinder Red Hat:openstack:16.1::el8 | All versions | 1:15.3.1-1.20200914173114.00ac80b.el8ost |
python3-cinder Red Hat:openstack:16.1::el8 | All versions | 1:15.3.1-1.20200914173114.00ac80b.el8ost |
Products include Canonical Ubuntu Linux, Redhat Openstack-Cinder.
How do I fix CVE-2020-10755?
Upgrade cinder to a fixed version for your release line: 14.1.0, 15.2.0 or 16.1.0.
Is CVE-2020-10755 being exploited?
There is no known exploitation of CVE-2020-10755 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2020-10755, GHSA-v3m2-pg96-w33m, PYSEC-2020-228, PYSEC-2026-891, RHSA-2020:4283, RHSA-2020:4391 and 2 more.