# CVE-2020-10755: Openstack cinder Improper handling of ScaleIO backend credentials

> Attackers can retrieve backend storage credentials via API calls, allowing unauthorized access to other users' volumes and management APIs.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-10755, GHSA-v3m2-pg96-w33m, PYSEC-2020-228, PYSEC-2026-891, RHSA-2020:4283, RHSA-2020:4391, UBUNTU-CVE-2020-10755, USN-4420-1

## What is CVE-2020-10755?

CVE-2020-10755 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 10 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2020-10755?

14 open source packages ship an affected version, including cinder and os-brick. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cinder` | PyPI | All versions | 14.1.0, 15.2.0, 16.1.0 |
| `cinder` | PyPI | From 14.0.0 | 14.1.0 |
| `cinder` | PyPI | From 14.0.0 | 14.1.0 |
| `cinder` | PyPI | From 15.0.0 | 15.2.0 |
| `cinder` | PyPI | From 15.0.0 | 15.2.0 |
| `cinder` | PyPI | From 16.0.0 | 16.1.0 |
| `cinder` | PyPI | From 16.0.0 | 16.1.0 |
| `os-brick` | PyPI | From 2.10.0 | 2.10.4 |
| `os-brick` | PyPI | From 2.10.0 | 2.10.4 |
| `os-brick` | PyPI | From 2.8.0 | 2.8.6, 2.10.4, 3.0.2 |
| `os-brick` | PyPI | From 2.8.0 | 2.8.6 |
| `os-brick` | PyPI | From 2.8.0 | 2.8.6 |
| `os-brick` | PyPI | From 3.0.0 | 3.0.2 |
| `os-brick` | PyPI | From 3.0.0 | 3.0.2 |
| `openstack-cinder` | Red Hat:openstack:13::el7 | All versions | 1:12.0.10-19.el7ost |
| `python-cinder` | Red Hat:openstack:13::el7 | All versions | 1:12.0.10-19.el7ost |
| `openstack-cinder` | Red Hat:openstack:16.1::el8 | All versions | 1:15.3.1-1.20200914173114.00ac80b.el8ost |
| `python3-cinder` | Red Hat:openstack:16.1::el8 | All versions | 1:15.3.1-1.20200914173114.00ac80b.el8ost |

Products: Canonical Ubuntu Linux, Redhat Openstack-Cinder.

## How do I fix CVE-2020-10755?

Upgrade cinder to a fixed version for your release line: 14.1.0, 15.2.0 or 16.1.0.

## Is CVE-2020-10755 being exploited?

There is no known exploitation of CVE-2020-10755 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10755 and fix it if it is affected.

What it is: CVE-2020-10755 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 10 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10755 in the wild and no public exploit code.

Affected packages and fixed versions:
- cinder (PyPI): affected all versions; fixed in 14.1.0, 15.2.0, 16.1.0
- cinder (PyPI): affected from 14.0.0; fixed in 14.1.0
- cinder (PyPI): affected from 14.0.0; fixed in 14.1.0
- cinder (PyPI): affected from 15.0.0; fixed in 15.2.0
- cinder (PyPI): affected from 15.0.0; fixed in 15.2.0
- cinder (PyPI): affected from 16.0.0; fixed in 16.1.0
- cinder (PyPI): affected from 16.0.0; fixed in 16.1.0
- os-brick (PyPI): affected from 2.10.0; fixed in 2.10.4
- os-brick (PyPI): affected from 2.10.0; fixed in 2.10.4
- os-brick (PyPI): affected from 2.8.0; fixed in 2.8.6, 2.10.4, 3.0.2
- os-brick (PyPI): affected from 2.8.0; fixed in 2.8.6
- os-brick (PyPI): affected from 2.8.0; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10755/ (Markdown: https://insights.sbomify.com/CVE-2020-10755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10755
- OSV: https://osv.dev/vulnerability/CVE-2020-10755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10755/
Summaries are generated and may contain mistakes; the official description above is the record.
