{"answers":{"affected":"3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-10793 in the wild and no public exploit code.","fix":"No fix published yet.","what":"CVE-2020-10793 is a high-severity vulnerability in n/a, published on 23 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-10793 and fix it if it is affected.\n\nWhat it is: CVE-2020-10793 is a high-severity vulnerability in n/a, published on 23 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-10793 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions up to 4.0.0; no fix listed\n- codeigniter4/framework (Packagist): affected all versions up to 4.0.0; no fix listed\n- codeigniter (Bitnami): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-10793/ (Markdown: https://insights.sbomify.com/CVE-2020-10793/index.md)","id":"CVE-2020-10793","markdown":"https://insights.sbomify.com/CVE-2020-10793/index.md","name":"CVE-2020-10793","record":{"aliases":["BIT-codeigniter-2020-10793","GHSA-jwqp-wh5g-4gmm"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"low_privilege","summary":"Attackers can gain privileges by modifying email IDs in a custom module, though the framework itself is disputed as the root cause.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"CodeIgniter through 4.0.0 allows remote attackers to gain privileges via a modified Email ID to the \"Select Role of the User\" page. NOTE: A contributor to the CodeIgniter framework argues that the issue should not be attributed to CodeIgniter. Furthermore, the blog post reference shows an unknown website built with the CodeIgniter framework but that CodeIgniter is not responsible for introducing this issue because the framework has never provided a login screen, nor any kind of login or user management facilities beyond a Session library. Also, another reporter indicates the issue is with a custom module/plugin to CodeIgniter, not CodeIgniter itself.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter Improper Privilege Management","id":"CVE-2020-10793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"privilege_escalation","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2020-10794"},"packages":[{"ecosystem":"Bitnami","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"codeigniter","purl":"pkg:bitnami/codeigniter","source":"BIT-codeigniter-2020-10793"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.0.0"],"package":"codeigniter4/framework","purl":null,"source":"GHSA-jwqp-wh5g-4gmm"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.0.0"],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-jwqp-wh5g-4gmm"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2020-10792"},"products":["n/a"],"published":"2020-03-23","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can gain privileges by modifying email IDs in a custom module, though the framework itself is disputed as the root cause.","url":"https://insights.sbomify.com/CVE-2020-10793/"}