# CVE-2020-10802: phpMyAdmin SQL injection vulnerability

> An attacker can execute arbitrary SQL commands via crafted database or table names during search operations in phpMyAdmin.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-phpmyadmin-2020-10802, DEBIAN-CVE-2020-10802, GHSA-f4cr-3xmc-2wpm, UBUNTU-CVE-2020-10802

## What is CVE-2020-10802?

CVE-2020-10802 is a high-severity SQL injection vulnerability in Debian Debian Linux, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-10802?

5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.9.0 | 4.9.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.9.0 | 4.9.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.2 |
| `phpmyadmin` | Bitnami | From 4.0.0 | 4.9.5, 5.0.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Phpmyadmin Phpmyadmin, Suse Package Hub.

## How do I fix CVE-2020-10802?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.5 or 5.0.2.

## Is CVE-2020-10802 being exploited?

There is no known exploitation of CVE-2020-10802 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10802 and fix it if it is affected.

What it is: CVE-2020-10802 is a high-severity SQL injection vulnerability in Debian Debian Linux, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10802 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.5
- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.5
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2
- phpmyadmin (Bitnami): affected from 4.0.0; fixed in 4.9.5, 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10802/ (Markdown: https://insights.sbomify.com/CVE-2020-10802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10802
- OSV: https://osv.dev/vulnerability/CVE-2020-10802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10802/
Summaries are generated and may contain mistakes; the official description above is the record.
