{"answers":{"affected":"5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 6 products.","exploited":"There is no known exploitation of CVE-2020-10803 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.5 or 5.0.2.","what":"CVE-2020-10803 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-10803 and fix it if it is affected.\n\nWhat it is: CVE-2020-10803 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-10803 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 4.9.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 4.9.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2\n- phpmyadmin (Bitnami): affected from 4.0.0; fixed in 4.9.5, 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-10803/ (Markdown: https://insights.sbomify.com/CVE-2020-10803/index.md)","id":"CVE-2020-10803","markdown":"https://insights.sbomify.com/CVE-2020-10803/index.md","name":"CVE-2020-10803","record":{"aliases":["BIT-phpmyadmin-2020-10803","DEBIAN-CVE-2020-10803","GHSA-fcww-8wvc-38q9","UBUNTU-CVE-2020-10803"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via crafted database entries that execute when viewed in phpMyAdmin, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"},{"product":"phpmyadmin","vendor":"phpmyadmin"},{"product":"package_hub","vendor":"suse"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results (in tbl_get_field.php and libraries/classes/Display/Results.php). The attacker must be able to insert crafted data into certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin SQL injection vulnerability","id":"CVE-2020-10803","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","opensuse:backports_sle","opensuse:leap","phpmyadmin:phpmyadmin"],"type":"xss","year":"2020"},"n_packages":5,"n_references":8,"next":{"headline":"phpMyAdmin SQL Injection","id":"CVE-2020-10804"},"packages":[{"ecosystem":"Bitnami","fixed":["4.9.5","5.0.2"],"introduced":["4.0.0","5.0.0"],"last_affected":[],"package":"phpmyadmin","purl":"pkg:bitnami/phpmyadmin","source":"BIT-phpmyadmin-2020-10803"},{"ecosystem":"Packagist","fixed":["4.9.5"],"introduced":["3.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-fcww-8wvc-38q9"},{"ecosystem":"Packagist","fixed":["4.9.5"],"introduced":["3.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-fcww-8wvc-38q9"},{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-fcww-8wvc-38q9"},{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-fcww-8wvc-38q9"}],"prev":{"headline":"phpMyAdmin SQL injection vulnerability","id":"CVE-2020-10802"},"products":["n/a"],"published":"2020-03-22","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via crafted database entries that execute when viewed in phpMyAdmin, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2020-10803/"}