{"answers":{"affected":"5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 5 products.","exploited":"There is no known exploitation of CVE-2020-10804 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.5 or 5.0.2.","what":"CVE-2020-10804 is a high-severity SQL injection vulnerability in Fedoraproject Fedora, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-10804 and fix it if it is affected.\n\nWhat it is: CVE-2020-10804 is a high-severity SQL injection vulnerability in Fedoraproject Fedora, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-10804 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2\n- phpmyadmin (Bitnami): affected from 4.0.0; fixed in 4.9.5, 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-10804/ (Markdown: https://insights.sbomify.com/CVE-2020-10804/index.md)","id":"CVE-2020-10804","markdown":"https://insights.sbomify.com/CVE-2020-10804/index.md","name":"CVE-2020-10804","record":{"aliases":["BIT-phpmyadmin-2020-10804","DEBIAN-CVE-2020-10804","GHSA-h65r-8fp8-w7cx","UBUNTU-CVE-2020-10804"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"low_privilege","summary":"A malicious user can craft a username to trigger SQL injection, allowing attackers to execute arbitrary SQL commands and potentially escalate privileges.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"},{"product":"phpmyadmin","vendor":"phpmyadmin"},{"product":"package_hub","vendor":"suse"}],"cvss":{"score":8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin SQL Injection","id":"CVE-2020-10804","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:backports_sle","opensuse:leap","phpmyadmin:phpmyadmin"],"type":"sql_injection","year":"2020"},"n_packages":5,"n_references":7,"next":{"headline":"eZ Publish Kernel and Legacy Unrestricted Upload of File with Dangerous Type","id":"CVE-2020-10806"},"packages":[{"ecosystem":"Bitnami","fixed":["4.9.5","5.0.2"],"introduced":["4.0.0","5.0.0"],"last_affected":[],"package":"phpmyadmin","purl":"pkg:bitnami/phpmyadmin","source":"BIT-phpmyadmin-2020-10804"},{"ecosystem":"Packagist","fixed":["4.9.5"],"introduced":["4.9.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-h65r-8fp8-w7cx"},{"ecosystem":"Packagist","fixed":["4.9.5"],"introduced":["4.9.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-h65r-8fp8-w7cx"},{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-h65r-8fp8-w7cx"},{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-h65r-8fp8-w7cx"}],"prev":{"headline":"phpMyAdmin SQL injection vulnerability","id":"CVE-2020-10803"},"products":["n/a"],"published":"2020-03-22","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A malicious user can craft a username to trigger SQL injection, allowing attackers to execute arbitrary SQL commands and potentially escalate privileges.","url":"https://insights.sbomify.com/CVE-2020-10804/"}