# CVE-2020-10804: phpMyAdmin SQL Injection

> A malicious user can craft a username to trigger SQL injection, allowing attackers to execute arbitrary SQL commands and potentially escalate privileges.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-phpmyadmin-2020-10804, DEBIAN-CVE-2020-10804, GHSA-h65r-8fp8-w7cx, UBUNTU-CVE-2020-10804

## What is CVE-2020-10804?

CVE-2020-10804 is a high-severity SQL injection vulnerability in Fedoraproject Fedora, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-10804?

5 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.9.0 | 4.9.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.9.0 | 4.9.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.0.2 |
| `phpmyadmin` | Bitnami | From 4.0.0 | 4.9.5, 5.0.2 |

Products: Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Phpmyadmin Phpmyadmin, Suse Package Hub.

## How do I fix CVE-2020-10804?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.9.5 or 5.0.2.

## Is CVE-2020-10804 being exploited?

There is no known exploitation of CVE-2020-10804 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10804 and fix it if it is affected.

What it is: CVE-2020-10804 is a high-severity SQL injection vulnerability in Fedoraproject Fedora, published on 22 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10804 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.5
- phpmyadmin/phpmyadmin (Packagist): affected from 4.9.0; fixed in 4.9.5
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.0.2
- phpmyadmin (Bitnami): affected from 4.0.0; fixed in 4.9.5, 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10804/ (Markdown: https://insights.sbomify.com/CVE-2020-10804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10804
- OSV: https://osv.dev/vulnerability/CVE-2020-10804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10804/
Summaries are generated and may contain mistakes; the official description above is the record.
