CVE-2020-10806 eZ Publish Kernel and Legacy Unrestricted Upload of File with Dangerous Type
Remote attackers can execute arbitrary code by uploading PHP files in eZ Publish, unless specific vhost restrictions are applied.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10806?
CVE-2020-10806 is a critical vulnerability in n/a, published on 22 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
eZ Publish Kernel before 5.4.14.1, 6.x before 6.13.6.2, and 7.x before 7.5.6.2 and eZ Publish Legacy before 5.4.14.1, 2017 before 2017.12.7.2, and 2019 before 2019.03.4.2 allow remote attackers to execute arbitrary code by uploading PHP code, unless the vhost configuration permits only app.php execution.
Weakness: CWE-434
Which versions are affected by CVE-2020-10806?
12 open source packages ship an affected version, including ezsystems/ezpublish-kernel and ezsystems/ezpublish-legacy. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
ezsystems/ezpublish-kernel Packagist | All versions | 5.4.14.1 |
ezsystems/ezpublish-kernel Packagist | All versions | 5.4.14.1 |
ezsystems/ezpublish-kernel Packagist | From 6.0 | 6.13.6.2 |
ezsystems/ezpublish-kernel Packagist | From 6.0 | 6.13.6.2 |
ezsystems/ezpublish-kernel Packagist | From 7.0 | 7.5.6.2 |
ezsystems/ezpublish-kernel Packagist | From 7.0 | 7.5.6.2 |
6 more packages
ezsystems/ezpublish-legacy Packagist | All versions | 5.4.14.1 |
ezsystems/ezpublish-legacy Packagist | All versions | 5.4.14.1 |
ezsystems/ezpublish-legacy Packagist | From 2017 | 2017.12.7.2 |
ezsystems/ezpublish-legacy Packagist | From 2017 | 2017.12.7.2 |
ezsystems/ezpublish-legacy Packagist | From 2019 | 2019.03.4.2 |
ezsystems/ezpublish-legacy Packagist | From 2019 | 2019.03.4.2 |
Products include Ez Ez Publish-Kernel, Ez Ez Publish-Legacy.
How do I fix CVE-2020-10806?
Upgrade ezsystems/ezpublish-kernel to a fixed version for your release line: 5.4.14.1, 6.13.6.2 or 7.5.6.2.
Is CVE-2020-10806 being exploited?
There is no known exploitation of CVE-2020-10806 in the wild and no public exploit code.
Sources
Also known as GHSA-54p5-gxq6-j98g.