# CVE-2020-10931: Denial of service in n/a

> Remote attackers can crash the Memcached daemon by sending a crafted binary protocol header, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-memcached-2020-10931, DEBIAN-CVE-2020-10931, GHSA-vqwp-x6cp-56g5

## What is CVE-2020-10931?

CVE-2020-10931 is a high-severity denial of service vulnerability in n/a, published on 24 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Memcached 1.6.x before 1.6.2 allows remote attackers to cause a denial of service (daemon crash) via a crafted binary protocol header to try_read_command_binary in memcached.c.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2020-10931?

1 open source package ship an affected version, including memcached. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `memcached` | Bitnami | From 1.6.0 | 1.6.2 |

Products: Memcached Memcached.

## How do I fix CVE-2020-10931?

Upgrade memcached to 1.6.2 or later.

## Is CVE-2020-10931 being exploited?

There is no known exploitation of CVE-2020-10931 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-46853](https://insights.sbomify.com/CVE-2023-46853/): Memory corruption in n/a (critical 9.8)
- [CVE-2016-8704](https://insights.sbomify.com/CVE-2016-8704/): Integer overflow in Memcached (critical 9.8)
- [CVE-2016-8705](https://insights.sbomify.com/CVE-2016-8705/): Integer overflow in Memcached (critical 9.8)
- [CVE-2026-47783](https://insights.sbomify.com/CVE-2026-47783/): Information disclosure in memcached (high 8.1)
- [CVE-2026-47784](https://insights.sbomify.com/CVE-2026-47784/): Information disclosure in memcached (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10931 and fix it if it is affected.

What it is: CVE-2020-10931 is a high-severity denial of service vulnerability in n/a, published on 24 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10931 in the wild and no public exploit code.

Affected packages and fixed versions:
- memcached (Bitnami): affected from 1.6.0; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10931/ (Markdown: https://insights.sbomify.com/CVE-2020-10931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10931
- OSV: https://osv.dev/vulnerability/CVE-2020-10931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10931/
Summaries are generated and may contain mistakes; the official description above is the record.
