CVE-2020-10960 MediaWiki makeCollapsible allows applying event handler to any CSS selector
Users can inject CSS classes to hide or show UI elements, bypassing intended interface restrictions, though direct XSS is not possible.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-10960?
CVE-2020-10960 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 3 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).
Weakness: CWE-74
Which versions are affected by CVE-2020-10960?
7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.31.0 | 1.31.7 |
mediawiki/core Packagist | From 1.31.0 | 1.31.7 |
mediawiki/core Packagist | From 1.33.0 | 1.33.3 |
mediawiki/core Packagist | From 1.33.0 | 1.33.3 |
mediawiki/core Packagist | From 1.34.0 | 1.34.1 |
mediawiki/core Packagist | From 1.34.0 | 1.34.1 |
1 more packages
mediawiki Bitnami | All versions | 1.34.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2020-10960?
Upgrade mediawiki/core to a fixed version for your release line: 1.31.7, 1.33.3 or 1.34.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-10960 being exploited?
There is no known exploitation of CVE-2020-10960 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2020-10960, DEBIAN-CVE-2020-10960, DSA-4651-1, GHSA-pfm2-mqwj-ggm5, MGASA-2020-0167, UBUNTU-CVE-2020-10960.